Bug 112345 - FILESAVE DOCX LibreOffice loses a Line object when saving a file as DOCX
Summary: FILESAVE DOCX LibreOffice loses a Line object when saving a file as DOCX
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Objects
  Show dependency treegraph
 
Reported: 2017-09-12 09:20 UTC by Gabor Kelemen (allotropia)
Modified: 2020-04-14 10:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The problematic document (24.18 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-09-12 09:20 UTC, Gabor Kelemen (allotropia)
Details
The document saved from LO 5.4 (15.05 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-09-12 09:21 UTC, Gabor Kelemen (allotropia)
Details
The original and saved documents in LO 5.4 with the Position and Size dialogs open (143.73 KB, image/png)
2017-09-12 09:22 UTC, Gabor Kelemen (allotropia)
Details
The original and saved documents in LO 5.4 with the Position and Size dialogs Rotation tab open (172.82 KB, image/png)
2017-09-12 09:26 UTC, Gabor Kelemen (allotropia)
Details
The document in LO 6.1.0.3 (187.11 KB, image/png)
2018-09-14 06:50 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2017-09-12 09:20:21 UTC
Created attachment 136193 [details]
The problematic document

This DOCX document was originally created in Microsoft Office and contains 4 Lines: two horizontal and two vertical. When the document is saved as DOCX in LibreOffice Writer the two vertical lines are saved with wrong position values. The document can be saved as ODT without any issue.

Steps to reproduce:
1. Open the original document (lost-line-original.docx) in LibreOffice.
2. Save the document as DOCX in LibreOffice Writer.

Actual results:
The vertical lines are preserved in the new DOCX file with the following properties modified (in case of the green one, red is pretty similar):

Height: from 25,97 cm to 29,70 cm (the side pane says 45,80 cm)

Horizontal position from -1,05 cm to 18,46 cm
Vertical position from 0,35 cm to -0,75 cm

Rotation / Pivot Point position X from -1,05 cm to 18,51 cm
Rotation / Pivot Point position Y from 13,34 cm to 0,36 cm

Expected results:
The vertical lines should be preserved with the same settings.
Comment 1 Gabor Kelemen (allotropia) 2017-09-12 09:21:15 UTC
Created attachment 136194 [details]
The document saved from LO 5.4
Comment 2 Gabor Kelemen (allotropia) 2017-09-12 09:22:10 UTC
Created attachment 136195 [details]
The original and saved documents in LO 5.4 with the Position and Size dialogs open
Comment 3 Gabor Kelemen (allotropia) 2017-09-12 09:26:50 UTC
Created attachment 136196 [details]
The original and saved documents in LO 5.4 with the Position and Size dialogs Rotation tab open
Comment 4 Xisco Faulí 2017-09-13 00:28:08 UTC
Regression introduced by:

author	Jacobo Aragunde Pérez <jaragunde@igalia.com>	2014-02-28 18:47:44 (GMT)
committer	Jacobo Aragunde Pérez <jaragunde@igalia.com>	2014-03-05 10:06:27 (GMT)
commit aad35298c43795e60605e0ea71290642687c8fc4 (patch)
tree e9c4bbec95cf0dabf2761b8c166c4c2797379680
parent 0415e2696156b25226f21085a0716187f83c2f4b (diff)
fdo#70838: fix size error in rotated shapes in DrawingML
We should pass the natural rectangle instead of the bounding box as
the size of the shape.

Bisected with bibisect-43max

Adding Cc: to Jacobo Aragunde Pérez
Comment 5 QA Administrators 2018-09-14 02:47:02 UTC Comment hidden (obsolete)
Comment 6 Gabor Kelemen (allotropia) 2018-09-14 06:50:35 UTC
Created attachment 144853 [details]
The document in LO 6.1.0.3

Opening is fine, but after saving the vertical objects still "disappear".
Comment 7 QA Administrators 2019-11-07 03:33:54 UTC Comment hidden (obsolete)
Comment 8 Aron Budea 2020-04-13 23:31:45 UTC
This could be fine now in 7.0.0.0.alpha0+ (95dbfd517240666e5b9a9fd7ac1d47d799235a62).

When the saved file is reopened, the vertical lines are shown as horizontal because of bug 122717, but when opening in a version earlier than that, or in Word, they looks good.

Reverse bibisecting pointed to the very recent commit that fixed bug 104565:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=08a11f8fe19560b000c62da00d7425b4f500d605
author		Szabolcs <szabolcs450@gmail.com>	2020-03-24 15:38:14 +0100
committer	László Németh <nemeth@numbertext.org>	2020-04-08 12:54:45 +0200

"tdf#104565 DOCX drawing object export: fix arrow positions"

Great, closing as FIXED.
Comment 9 Xisco Faulí 2020-04-14 10:42:05 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 35fc5ef0a759884b24ed8b83cd05702a0fab64cc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded