Bug Hunting Session
Bug 112371 - FILEOPEN XLSX LibreOffice Calc doesn't support Excel Table Styles
Summary: FILEOPEN XLSX LibreOffice Calc doesn't support Excel Table Styles
Status: RESOLVED DUPLICATE of bug 66377
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL: https://support.office.com/en-us/arti...
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: Table-Styles
  Show dependency treegraph
 
Reported: 2017-09-13 13:25 UTC by Gabor Kelemen
Modified: 2019-03-08 06:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document with table styles used (16.31 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-09-13 13:25 UTC, Gabor Kelemen
Details
The sample file opened in Excel and LO (139.43 KB, image/png)
2017-09-13 13:27 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-09-13 13:25:20 UTC
Created attachment 136225 [details]
Sample document with table styles used

Excel offers predefined table styles to quickly format a table. LibreOffice Calc is unable to display the custom color scheme of these tables in spreadsheets saved as XLSX files.

Steps to reproduce:
1. Create a new spreadsheet in Microsoft Excel.
2. Select an area.
3. Click the Format as Table button in the Styles group on the Home tab and choose a table style.
4. Save the file as XLSX.
5. Open the file in LibreOffice Calc.

Actual results:
The table loses are color settings made with the Table Styles feature in Excel.

Expected results:
The table should retain the same colors as in Excel.
Comment 1 Gabor Kelemen 2017-09-13 13:27:59 UTC
Created attachment 136226 [details]
The sample file opened in Excel and LO
Comment 2 raal 2017-09-13 19:33:55 UTC
Confirm. Version: 6.0.0.0.alpha0+
Comment 4 Gabor Kelemen 2018-12-18 14:16:25 UTC
*** Bug 122109 has been marked as a duplicate of this bug. ***
Comment 5 Roman Kuznetsov 2019-01-27 15:06:01 UTC
*** Bug 122917 has been marked as a duplicate of this bug. ***
Comment 6 Aron Budea 2019-03-08 06:03:49 UTC

*** This bug has been marked as a duplicate of bug 66377 ***