Download it now!
Bug 112448 - FILEOPEN, DOCX spurious blank line in text
Summary: FILEOPEN, DOCX spurious blank line in text
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Serge Krot (CIB)
URL:
Whiteboard: target:6.1.0 target:6.0.4
Keywords: filter:docx
Depends on:
Blocks: DOCX-Paragraph
  Show dependency treegraph
 
Reported: 2017-09-17 17:16 UTC by Oliver Sander
Modified: 2018-03-23 22:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The file that triggers the problem (64.54 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-09-17 17:16 UTC, Oliver Sander
Details
The file as rendered by LO 5.4.1.2 (50.87 KB, application/pdf)
2017-09-17 17:17 UTC, Oliver Sander
Details
The file as rendered by MSOffice (35.86 KB, application/pdf)
2017-09-17 17:17 UTC, Oliver Sander
Details
minimal file causing the bug (13.19 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-10-09 11:52 UTC, Patrick Jaap
Details
rednering of the minimal file by master, 4.3 and MSO 2013 (17.88 KB, application/pdf)
2017-10-09 11:54 UTC, Patrick Jaap
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Sander 2017-09-17 17:16:12 UTC
Description:
When opening the attached docx document (a letter template), LO inserts a spurious blank line after the line with place and date.

Actual Results:  
 

Expected Results:
 


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 Oliver Sander 2017-09-17 17:16:38 UTC
Created attachment 136303 [details]
The file that triggers the problem
Comment 2 Oliver Sander 2017-09-17 17:17:00 UTC
Created attachment 136304 [details]
The file as rendered by LO 5.4.1.2
Comment 3 Oliver Sander 2017-09-17 17:17:25 UTC
Created attachment 136305 [details]
The file as rendered by MSOffice
Comment 4 Xisco Faulí 2017-09-17 21:49:36 UTC
Confirmed in 

Version: 6.0.0.0.alpha0+
Build ID: 83288332f7ced698610739419989c464256f1c4d
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

- Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

- Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

- Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

- LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 5 Patrick Jaap 2017-10-09 11:52:27 UTC
Created attachment 136861 [details]
minimal file causing the bug

A minimal file with lines "1" and "2" and a textbox "A" in between. Since "no wrap" is specified, there should be no empty line underneath the textbox.
Comment 6 Patrick Jaap 2017-10-09 11:54:50 UTC
Created attachment 136862 [details]
rednering of the minimal file by master, 4.3 and MSO 2013

Screenshots of LO and MSO:

Current master (both Windows build and Linux build) creates an empty line underneath the textbox.

Office 2013 shows no empty line.
Comment 7 Commit Notification 2018-03-15 15:54:30 UTC
Serge Krot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c3f10da500967fc6ffecc2f3e076d8ff43e7503

tdf#112448: Fix: take correct line height

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Oliver Sander 2018-03-16 12:10:54 UTC
I confirm that the bug is fixed.  Many thanks!

Can we please get a backport to the 6.0 branch?
Comment 9 Commit Notification 2018-03-23 22:56:51 UTC
Serge Krot committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=169fe61fe32587897188ed5b3619af34f394731d&h=libreoffice-6-0

tdf#112448: Fix: take correct line height

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.