Bug 112457 - Method to deactivate notebookbar in groupedbar compact mode not discoverable
Summary: Method to deactivate notebookbar in groupedbar compact mode not discoverable
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Groupedbar
  Show dependency treegraph
 
Reported: 2017-09-17 21:16 UTC by sergio.callegari
Modified: 2018-06-25 20:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2017-09-17 21:16:10 UTC
Description:
When testing the notebookbar, one may easily get stuck with it without knowing how to go back.

Specifically, in the groupedbar compact there does not seem to be a way to switch to anything else, since: (i) no menus are shown; (ii) there does not seem a way to activate the menus; (iii) the view item in the compact groupedbar does not seem to include anything having to do with the notebookbar mode.

Steps to Reproduce:
1. Activate notebookbar (View->Toolbar layout->Notebookbar)
2. Put notebookbar in Groupedbar compact mode (View -> Notebookbar -> Groupedbar compact)
3. Try to go back to the default toolbar layout.

Incidentally, the Notebookbar menu entry should probably not be shown unless the Notebookbar is active (but this should probably be reported independently).

Actual Results:  
The way to go back to the default toolbar is absent (or hard to discover ?)

Expected Results:
There should be an easy way to re-activate menus and an easy way to go back to the default toolbar layout.


Reproducible: Always

User Profile Reset: No

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Builds ID: LibreOffice 5.4.1.2


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 V Stuart Foote 2017-09-18 02:38:38 UTC
The Menu "hamburger" is at the right edge of the compact groupedbar.

Click to toggle the main menu visible, change notebook bar mode there.
Comment 2 sergio.callegari 2017-09-18 08:55:29 UTC
Reopening as the point is that it is not discoverable enough, then.

1) Icon almost identical to the one of text align justify (at least with kde integration)

2) No tooltip. Are users expected to click all buttons of the notebookbar to find the one to get the menus?

3) Not on the "View" region of the notebookbar. Conversely, the "View" region has an icon whose tooltip says "Shows or hides the menus [...] in writer and calc" which actually does not let you show the menu (since it enters and exists fullscreen mode, basically).

4) No mention of it in the online help.

5) Not consistent with the "standard" (i.e., not compact) groupedbar, where the button to get the menus back is pushed totally to the right, to separate it from the rest of the buttons.
Comment 3 sergio.callegari 2017-09-18 08:56:27 UTC
Would be great if the menu button could be at least given a tooltip and pushed to the right as for the standard groupedbar
Comment 4 Xisco Faulí 2017-09-18 08:57:31 UTC
(In reply to V Stuart Foote from comment #1)
> The Menu "hamburger" is at the right edge of the compact groupedbar.
> 
> Click to toggle the main menu visible, change notebook bar mode there.

I agree with V Stuart. Anyway, let's add the UX team here to hear their opinion
Comment 5 Heiko Tietze 2017-09-18 09:57:19 UTC
The feature is experimental and therefor not every aspect is perfect. Nevertheless I think a generic approach makes sense and I recommend to not only activate the menubar with F10 but also to show it when hidden. (Restore previous visibility when the focus goes somewhere else)

This solution could be an easyhack.
Comment 6 sergio.callegari 2017-09-18 10:06:33 UTC
My intention was precisely to provide feedback so that it can be at the maximum possible quality when it comes out of experimental status.
Comment 7 Heiko Tietze 2018-04-11 08:52:28 UTC
The situation has improved meanwhile. So WFM.

However, the checkbox Menu > Menu bar is not working in master. And the idea of F10 temporarily showing the menu bar if hidden is worth to discuss too. So keeping the ticket open.
Comment 8 andreas_k 2018-06-25 20:59:22 UTC
(In reply to Heiko Tietze from comment #7)
> The situation has improved meanwhile. So WFM.
> 
> However, the checkbox Menu > Menu bar is not working in master. And the idea
> of F10 temporarily showing the menu bar if hidden is worth to discuss too.
> So keeping the ticket open.

As checkbox in Menu > Menubar work now on all implementations this can be closed. Fixed in LibreOffice 6.1