Bug Hunting Session
Bug 112459 - FILESAVE: Linked Cell of Checkbox lost
Summary: FILESAVE: Linked Cell of Checkbox lost
Status: RESOLVED DUPLICATE of bug 110431
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-17 21:54 UTC by Johannes Schneider
Modified: 2017-09-18 19:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Open document sheet containig a check box (9.21 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-09-17 21:54 UTC, Johannes Schneider
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Schneider 2017-09-17 21:54:11 UTC
Created attachment 136322 [details]
Open document sheet containig a check box

I created a check box in an .ODS-Document and assigned a cell to it. After saving and reopening the linked cell was lost (no longer existing in the properties of the check box).

In the .XLS-format it is working properly; in the XLSX-format the check box itself gets lost (known as bug 69098).
Comment 1 Xavier Van Wijmeersch 2017-09-18 06:58:34 UTC
confirm with

Version: 6.0.0.0.alpha0+
Build ID: afeff9102c2935139de4efd40fd2286dce396706
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-09-17_23:32:41
Locale: nl-BE (en_US.UTF-8); Calc: group

and

Version: 5.4.2.0.0+
Build ID: 61d85c4e7c30ea0f5242d927b7456190020b4fbe
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group

also it will say read only document????
Comment 2 Johannes Schneider 2017-09-18 16:23:40 UTC
> also it will say read only document????
No. I can still change the file.
Comment 3 raal 2017-09-18 19:20:21 UTC
ommit 8154953add163554c00935486a1cf5677cef2609

closing as duplicate

*** This bug has been marked as a duplicate of bug 110431 ***