Bug 112488 - Embedded images in header disappear after saving in docx format
Summary: Embedded images in header disappear after saving in docx format
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Header-Footer
  Show dependency treegraph
 
Reported: 2017-09-19 09:09 UTC by fabrizio
Modified: 2019-02-27 03:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Testcase file (86.18 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-09-19 09:16 UTC, fabrizio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fabrizio 2017-09-19 09:09:00 UTC
Description:
Lots of DOCX documents coming from MSWord that have images in their header are not rendered correctly after saving them using LibreOffice and keeping the same DOCX format.

This happens often in documents that have multiple pages and different headers between the first page and the other ones.
As you can see in the example file that I've attached to this bug, if you try to save the file with LibreOffice, the header images from page 3 to 4 will disappear.

I'm using Libre 5.4.1.2 x64 under Windows 8.1 but the problem is present under Ubuntu Linux, as well.

Steps to Reproduce:
Can't reproduce it from scratch. However you can use the example file I've attached.
1. Open the file with LibreOffice. Check that the header image is displayed in all the pages.
2. Save it again keeping the DOCX format
3. Reopen it (using MSWord or Libreoffice)
4. Check that from page 3 the header image is missing.

Actual Results:  
No header images from page 3

Expected Results:
I'm expecting that all the pages have the same header image that was displayed before saving the document.


Reproducible: Couldn't Reproduce

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 fabrizio 2017-09-19 09:15:19 UTC
Please note that sometimes the images from page 3 aren't displayed *even before* saving the document, while they're present if you open the document using MSWord.
Comment 2 fabrizio 2017-09-19 09:16:07 UTC
Created attachment 136362 [details]
Testcase file
Comment 3 Xisco Faulí 2017-09-19 10:46:30 UTC
The problem is at import time as the image in header is only displayed in first and second page, but not in the third and the forth. I guess this is the same issue as in bug 57155

Closing as RESOLVED DUPLICATED

Thanks for reporting this issue!

*** This bug has been marked as a duplicate of bug 57155 ***
Comment 4 Luke 2018-02-26 00:38:30 UTC
Xisco Faulí,
I can't see how this could possibly be a dupe. This opens the file correctly and is a file SAVE issue. The other is a file OPEN issue. Highly doubt they are the same.
Comment 5 QA Administrators 2019-02-27 03:56:20 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug