Bug 112544 - DOCX: Incorrect layout of table in Writer
Summary: DOCX: Incorrect layout of table in Writer
Status: RESOLVED DUPLICATE of bug 61594
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks:
 
Reported: 2017-09-21 09:49 UTC by vojtech.fric
Modified: 2018-01-25 11:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document which shows the problem (53.62 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-09-21 09:51 UTC, vojtech.fric
Details
PDF conversions of the Test-tezky.docx in various version of Writer and Word (719.09 KB, application/x-zip-compressed)
2017-09-21 09:52 UTC, vojtech.fric
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vojtech.fric 2017-09-21 09:49:30 UTC
Description:
There is major difference when displaying Microstoft Office 2013 Docx document, containing table. The table on the first page of attached document is displayed to the right in Libre 5.3 (correct placement, same as in MS Word), but it is displayed to the left in the Libre 5.4.

I have tested it in the following versions:
5.3.1 on Ubuntu - Build ID: 1:5.3.1-0ubuntu2 - from package manager
5.4.1 on Ubuntu - Version: 5.4.1.2 Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527 - manual install from the website (https://www.libreoffice.org/)

5.3.6 on Windows 10x64 - LibreOffice_5.3.6_Win_x86.msi - manual install from the website (https://www.libreoffice.org/)
5.4.1 on Windows 10x64 - LibreOffice_5.4.1_Win_x86.msi - manual install from the website (https://www.libreoffice.org/)

The 5.3 version are working correctly. The versions 5.4 are displaying incorrect results.

Steps to Reproduce:
1. Open document Test-tezky.docx in Libre 5.3
2. Open document Test-tezky.docx in Libre 5.4


Actual Results:  
In Writer 5.4 table on the first page (containing Jan NOVAK,  r. nar. 1900, etc.) is displayed on the left side.

Expected Results:
In Writer 5.4 table on the first page (containing Jan NOVAK,  r. nar. 1900, etc.) is displayed on the right side. (same as in MS Word and Libre 5.3)


Reproducible: Always

User Profile Reset: No

Additional Info:
Both testing OS are 64bit, and runnnig JRE 1.8.


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 vojtech.fric 2017-09-21 09:51:04 UTC
Created attachment 136420 [details]
Test document which shows the problem
Comment 2 vojtech.fric 2017-09-21 09:52:22 UTC
Created attachment 136421 [details]
PDF conversions of the Test-tezky.docx in various version of Writer and Word
Comment 3 Xisco Faulí 2017-09-21 10:16:40 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2017-05-16 13:26:53 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-05-16 16:57:00 (GMT)
commit	659c0227a50d298780d72902314e03df8824bc06 (patch)
tree	f83ec0b8ef994ff91b79b95ed0b738b415a8de96
parent	d849231dd2064ebed96d17bf54286a33954304ab (diff)
tdf#107889 DOCX import: consider page breaks for multi-page floattables
This is the DOCX equivalent of commit
6aba29576df7a2a40e54040d4dd09d94d6594741 (tdf#107773 DOC import:
consider page breaks for multi-page floattables, 2017-05-11): a specific
case where it's clearly superior to import a multi-page floating table
as a multi-page one, rather than a floating one.

Bisected with: bibisect-linux-64-5.4

Adding Cc: to Miklos Vajna
Comment 4 Miklos Vajna 2017-09-21 22:16:29 UTC
I think the root cause is bug 61594 here, where Writer does not have the floating multi-page table what Word has. This bug is just one more manifestation of that problem. No matter how hard to try to do heuristics to guess if the multi-page of the floating table mode of Writer will fit the situation best, somebody will be unhappy. The real solution will be the feature, which is the tracked at the bug I mentioned.

OK to close as duplicate?
Comment 5 Xisco Faulí 2018-01-25 11:48:12 UTC

*** This bug has been marked as a duplicate of bug 61594 ***