Bug Hunting Session
Bug 112562 - 'Random' number displayed on style organizer page
Summary: 'Random' number displayed on style organizer page
Status: RESOLVED DUPLICATE of bug 112563
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-22 06:24 UTC by Oliver Specht (CIB)
Modified: 2017-09-22 06:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (36.99 KB, image/png)
2017-09-22 06:24 UTC, Oliver Specht (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Specht (CIB) 2017-09-22 06:24:16 UTC
Created attachment 136450 [details]
screenshot

Load the attached document and edit the character style 'Page Number#
On the organizer page one can see after the list of bold and italic attributes a '+ 18338537' that doesn't belong there.

To achieve this 
- a character style has to be applied to some text
- some additional character attribute needs to be applied to that text
- in stylist call 'Update style' on that character style

Should also be reproducible with paragraph styles.

Has been introduced with 
commit 062eaeffe7cb986255063bb9b0a5f3fb3fc8e34c
Date:   Thu Dec 22 17:27:32 2011 +0100

    sw: Improved document comparison based on RSIDs.

The ids RES_CHRATR_RSID and RES_PARATR_RSID have been added to the range of character / paragraph attributes.
Comment 1 Julien Nabet 2017-09-22 06:52:20 UTC
dup of tdf#112563? Indeed I don't see the diff between both.
Comment 2 Oliver Specht (CIB) 2017-09-22 06:58:58 UTC

*** This bug has been marked as a duplicate of bug 112563 ***