Bug 112563 - 'Random' number displayed on style organizer page
Summary: 'Random' number displayed on style organizer page
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0 target:6.1.1
Keywords: bibisected, bisected, regression
: 112562 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-22 06:24 UTC by Oliver Specht (CIB)
Modified: 2018-08-27 15:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (36.99 KB, image/png)
2017-09-22 06:25 UTC, Oliver Specht (CIB)
Details
bugdoc (9.20 KB, application/vnd.oasis.opendocument.text)
2017-09-22 06:25 UTC, Oliver Specht (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Specht (CIB) 2017-09-22 06:24:32 UTC
Load the attached document and edit the character style 'Page Number#
On the organizer page one can see after the list of bold and italic attributes a '+ 18338537' that doesn't belong there.

To achieve this 
- a character style has to be applied to some text
- some additional character attribute needs to be applied to that text
- in stylist call 'Update style' on that character style

Should also be reproducible with paragraph styles.

Has been introduced with 
commit 062eaeffe7cb986255063bb9b0a5f3fb3fc8e34c
Date:   Thu Dec 22 17:27:32 2011 +0100

    sw: Improved document comparison based on RSIDs.

The ids RES_CHRATR_RSID and RES_PARATR_RSID have been added to the range of character / paragraph attributes.
Comment 1 Oliver Specht (CIB) 2017-09-22 06:25:01 UTC
Created attachment 136451 [details]
screenshot
Comment 2 Oliver Specht (CIB) 2017-09-22 06:25:32 UTC
Created attachment 136452 [details]
bugdoc
Comment 3 Oliver Specht (CIB) 2017-09-22 06:58:58 UTC
*** Bug 112562 has been marked as a duplicate of this bug. ***
Comment 4 Xisco Faulí 2017-09-22 23:25:23 UTC
Hello Oliver,
Based on the commit which introduced the issue, it's the same as in bug 65925.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 65925 ***
Comment 5 Michael Stahl (CIB) 2017-09-25 11:08:53 UTC
not sure why you'd think that some odd RSID number in a dialog is a duplicate of a HTML export issue?

of course the RSID should not be displayed on the dialog, so NEW.
Comment 6 Commit Notification 2018-08-24 07:21:05 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d204dddc9aa1919ef94add3a7dfb40087ccceb4b

Resolves: tdf#112563 we don't want a human representation of SvxRsidItem

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-08-24 08:58:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bd64800ef579b5d4653ee3dfb90c45874a15a9fa&h=libreoffice-6-1

Resolves: tdf#112563 we don't want a human representation of SvxRsidItem

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-08-27 15:09:11 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 63f8c506637c910ed1efa572f23ff1af7715e7e3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Caolán, Thanks for fixing this!!