Download it now!
Bug 112668 - In a category axis with date scale, missing data should be skipped and not be assumed zero
Summary: In a category axis with date scale, missing data should be skipped and not be...
Status: RESOLVED DUPLICATE of bug 42915
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart-Enhancements
  Show dependency treegraph
 
Reported: 2017-09-26 15:14 UTC by Regina Henschel
Modified: 2020-05-25 15:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Date scale x-axis with gap (52.64 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-09-26 15:14 UTC, Regina Henschel
Details
Screenshot of the document in current Calc (190.42 KB, image/png)
2020-05-25 15:56 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2017-09-26 15:14:55 UTC
Created attachment 136550 [details]
Date scale x-axis with gap

If in a chart with x-axis set to date scale a series value does not have a corresponding date, then LibreOffice assumes, that the date is 0. That results in ugly charts. It would be better, if the data point is skipped, same as Excel does it.

The attachment has a screenshot, how the chart looks in Excel.

It is not an import problem. You get the same ugly chart, if you generate the chart from scratch.
Comment 1 m.a.riosv 2017-09-27 08:27:28 UTC
Reproducible.
Version: 6.0.0.0.alpha0+
Build ID: 83288332f7ced698610739419989c464256f1c4d
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: es-ES (es_ES); Calc: CL

But please take a look saving the file as xlsx with LibreOffice and reload.
Date's column lose the width but the chart looks nice.
That's no happen saving as ods.
Comment 2 NISZ LibreOffice Team 2020-05-25 15:56:07 UTC
Created attachment 161268 [details]
Screenshot of the document in current Calc

This looks good since:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=55c5382591305a872b961d54571e3c823728ccb2

author	Markus Mohrhard <markus.mohrhard@googlemail.com>	2018-11-29 19:11:58 +0100
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2018-11-30 13:17:27 +0100

tdf#42915, NaN in a date axis can destroy the whole chart
Comment 3 NISZ LibreOffice Team 2020-05-25 15:56:48 UTC

*** This bug has been marked as a duplicate of bug 42915 ***