Download it now!
Bug 112807 - AutoCorrect Emoji support does not work for traditional Chinese
Summary: AutoCorrect Emoji support does not work for traditional Chinese
Status: RESOLVED DUPLICATE of bug 93846
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2017-10-02 04:12 UTC by Cheng-Chia Tseng
Modified: 2017-10-02 08:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cheng-Chia Tseng 2017-10-02 04:12:00 UTC
LibreOffice released Emoji and in-word replacement support since 5.0 version. 

For example, in traditional Chinese we translate "registered" string wich is ® (U+000AE) in extras/source/autocorr/emoji.po as "註冊商標". It is expected AutoCorrect can replace the text of :註冊商標: in Chinese (traditional) locale to ® emoji symbol. However, AutoCorrect does not work for traditional Chinese in this case.

Reproduce steps:
1. Type or cut and paste :註冊商標: to Writer
2. press Enter to expect AutoCorrect to work and replace :註冊商標: to ®

Result:
Nothing happened. :註冊商標: is still :註冊商標:

Reproducibple:
Always

Expected Result:
:註冊商標: should be replaced with ® like :registered: does.
Comment 1 Xisco Faulí 2017-10-02 08:29:17 UTC
Thanks for reporting this is issue.
It seems like a dupe of bug 93846 to me.
Regards

*** This bug has been marked as a duplicate of bug 93846 ***