Bug Hunting Session
Bug 112834 - RTL: Input fields rendered incorrectly (gtk2)
Summary: RTL: Input fields rendered incorrectly (gtk2)
Status: RESOLVED DUPLICATE of bug 112827
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: RTL-CTL GTK2
  Show dependency treegraph
 
Reported: 2017-10-02 14:47 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-04 19:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of sidebar (42.84 KB, image/png)
2017-10-02 14:47 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-10-02 14:47:26 UTC
Created attachment 136697 [details]
screenshot of sidebar

steps:
1. open writer with Arabic UI
2. look at the controls in the toolbar or sidebar

This only happens in gtk2.

Version: 6.0.0.0.alpha0+
Build ID: a2a3e06a29077d4274dc15eea28a01afe22e3658
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Xisco Faulí 2017-10-02 15:00:58 UTC Comment hidden (obsolete)
Comment 2 Xisco Faulí 2017-10-02 21:48:17 UTC
Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: fe301bbbfce1d11ab992c4ec2a3cb866629e5c04
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 Xisco Faulí 2017-10-02 22:46:07 UTC
Locally applied https://gerrit.libreoffice.org/#/c/43057/ and it's resolved.
Closing as duplicate of bug 112827

*** This bug has been marked as a duplicate of bug 112827 ***
Comment 4 Lior Kaplan 2017-10-03 05:15:28 UTC
(In reply to Xisco Faulí from comment #3)
> Locally applied https://gerrit.libreoffice.org/#/c/43057/ and it's resolved.
> Closing as duplicate of bug 112827

Could you mention this in gerrit as well?
Comment 5 Yousuf Philips (jay) (retired) 2017-10-04 19:38:24 UTC
Yes it seems to be fixed.

build id: 6e3e4cd38b56d432c48cd7217885974e3f0519fd