Bug 112836 - In master view, bottom areas are wrongly positioned
Summary: In master view, bottom areas are wrongly positioned
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0 target:5.4.3
Keywords: bibisected, bisected, regression
: 107268 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-02 16:55 UTC by Eugen Dedu
Modified: 2017-10-27 11:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugen Dedu 2017-10-02 16:55:14 UTC
Description:
Hi,

Start a new presentation.  Use View->SlideMaster in the menu to open the master view.  The three area at the bottom are, in this order:
Slide Number Area / Date Area / Footer area

This is wrong.  Until recently, loimpress has always presented them in the following order:
Date Area / Footer Area / Slide Number Area

The effect is that when I tell LO to add/show slide number, it is shown at bottom left instead of bottom right, as it has always been the case.

Tested with 5.4.1 and 5.4.2~rc1, from debian.

Cheers,
Eugen

Actual Results:  
See bug report

Expected Results:
See bug report


Reproducible: Always

User Profile Reset: No, but I tested on another user and the problem is there too.

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Xisco Faulí 2017-10-02 22:13:50 UTC
Regression introduced by:

author	Noel Grandin <noel.grandin@collabora.co.uk>	2017-02-15 07:36:42 (GMT)
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2017-02-15 07:36:42 (GMT)
commit	12b2803f196b897ffb901b0eebe271c5ee43d03e (patch)
tree	8088460395c4062e5065997a285f02c40e8da694
parent	87f3fd05eb2e8ca3a0cdf449d3e2c66cfd3a57bf (diff)
drop unused PRESOBJ_IMAGE

Bisected with: bibisect-linux-64-5.4

Adding Cc: to Noel Grandin
Comment 2 Commit Notification 2017-10-03 09:02:10 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d352dda3dbfc9e26b7f80746e1502f3cb4cd45c1

tdf#112836 master view, bottom areas are wrongly positioned

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Eugen Dedu 2017-10-03 09:17:33 UTC
Thank you, Noel.

Would it be possible to commit it to 5.4 branch too, for 5.4.2?  It does not seem intrusive.  When a user starts a new presentation it is very difficult for him to put the page number for example at the right position.  Moreover, once a user started its presentation with the wrong bottom areas (as it is currently), there is no way to fix it later; thus, I hesitate to start my new course, I prefer to wait once it is finished, if it is not too late.
Comment 4 Commit Notification 2017-10-04 08:24:07 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e609558c98b7610928507a819ec30a2879fc2ca1&h=libreoffice-5-4

tdf#112836 master view, bottom areas are wrongly positioned

It will be available in 5.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2017-10-04 09:55:16 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-5-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=31423b7d44216606cac52ebaf4eab02f469c478f&h=libreoffice-5-4-2

tdf#112836 master view, bottom areas are wrongly positioned

It will be available in 5.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2017-10-05 08:29:35 UTC
although this commit is in LibreOffice 5.4.2, I'm afraid it was done after the tagging for 5.4.2, thus it won't be in that version but in the next one, LibreOffice 5.4.3
Comment 7 Regina Henschel 2017-10-23 11:47:19 UTC
*** Bug 107268 has been marked as a duplicate of this bug. ***
Comment 8 Eugen Dedu 2017-10-27 11:19:26 UTC
I confirm it is fixed, thank you.