Bug 112840 - Can't replace all the underlined text with nothing
Summary: Can't replace all the underlined text with nothing
Status: RESOLVED DUPLICATE of bug 99672
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-02 17:44 UTC by ask4support
Modified: 2021-06-28 14:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A test file (9.41 KB, application/vnd.oasis.opendocument.text)
2017-10-02 17:45 UTC, ask4support
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ask4support 2017-10-02 17:44:37 UTC
Description:
When replacing all the underlined characters with nothing, the popup will show how many occurrences were replaced, but no underlined characters are actually removed. 

Steps to Reproduce:
1. Open the test file. 
2. Open up the "Find & Replace" dialog. 
3. Enable "Regular expressions"
4. Click  "Attributes" 
5. Enable "Underline"
6. Make sure that the "Replace with" field is empty and put ".*" in the search field. 
7. Click "Replace All"
8. A dialog is shown but nothing actually happens. 

Actual Results:  
A dialog is shown showing the number of times the key has been replaced. 
All the underlined text is selected. 
None of the underlined text is actually replaced (removed). 

Expected Results:
A dialog is shown showing the number of times the key has been replaced. 
All the underlined text should be replaced. 


Reproducible: Always

User Profile Reset: Yes

Additional Info:
I set the different home directory, so that I could switch to English without affecting my present UserProfile, I believe it's the same as running from a clear installation. 


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36
Comment 1 ask4support 2017-10-02 17:45:56 UTC
Created attachment 136704 [details]
A test file
Comment 2 Xisco Faulí 2017-10-03 21:13:21 UTC
Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: 34e8fd7e99489e9f50a512b07c6f3923b358b4d3
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 ask4support 2017-10-21 14:52:19 UTC
The same thing happens when trying to replace text with specific color with nothing.
Comment 4 QA Administrators 2018-10-22 02:47:46 UTC Comment hidden (obsolete)
Comment 5 keter 2018-11-29 09:05:32 UTC
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded

Still exists in version 6.3.0.0.alpha0+ (x64)
Comment 6 QA Administrators 2019-11-30 03:38:45 UTC Comment hidden (obsolete)
Comment 7 Stéphane Guillou (stragu) 2021-06-28 14:10:37 UTC

*** This bug has been marked as a duplicate of bug 99672 ***