Bug 112870 - Cannot change/set paragraph style in numbering organizer
Summary: Cannot change/set paragraph style in numbering organizer
Status: RESOLVED DUPLICATE of bug 119052
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Styles-List Styles-Dialog
  Show dependency treegraph
 
Reported: 2017-10-04 10:40 UTC by Ulrich Gemkow
Modified: 2018-10-18 08:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot Numbering style dialog (36.34 KB, image/jpeg)
2017-10-04 20:00 UTC, Dieter Praas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Gemkow 2017-10-04 10:40:35 UTC
I want assign a paragraph style to a numbering style (i.e. setting the paragraph style "List content" to "List 1"). I assume this should be possible by setting the style in the Oranizer tab of the numbering style.

But when trying this, the "Edit style" button is shown twice and neither of these buttons does anything when selecting.

To reproduce:

- Press F11

- Select the "Styles and Formatting"-View with the List styles

- Press the right mouse button on one of the styles (i.e. "List 1"), select "Modify"

- In the organizer tab you see the "Edit Style" button twice and nothing happens when
  selecting one the these.

I have no idea how this is supposed to work but I think currently something is wrong.

Thanks!
Comment 1 Dieter Praas 2017-10-04 20:00:09 UTC
Created attachment 136766 [details]
Screenshot Numbering style dialog
Comment 2 Dieter Praas 2017-10-04 20:05:19 UTC
I agree:
a) The first "Edit style" is superfluous.
b) The second "Edit style" should be grayed out, if "inherit from" is also grayed out (see attachment in comment 1)
Comment 3 Xisco Faulí 2017-10-17 10:56:39 UTC
*** Bug 113180 has been marked as a duplicate of this bug. ***
Comment 4 QA Administrators 2018-10-18 02:49:58 UTC Comment hidden (obsolete)
Comment 5 Roman Kuznetsov 2018-10-18 08:34:01 UTC
List styles don't have parent mechanism, therefore you can't edit "Inherrit from" style and second button "Edit" was removed in bug 119052

Let's make it as duplicate of 119052

*** This bug has been marked as a duplicate of bug 119052 ***