Bug 112884 - Error string is displayed as empty item in pivot table
Summary: Error string is displayed as empty item in pivot table
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:6.0.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-10-04 20:32 UTC by Tamás Zolnai
Modified: 2017-10-07 14:45 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Simple pivot table with an error item (11.81 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-10-04 20:33 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2017-10-04 20:32:34 UTC
Description:
I found this issue only on master, so must a recent regression. If I create a pivot table which has some error cells in its source range, then the error strings are not displayed in the pivot table layout. They are replaced with the "(empty)" string.
I can't reproduce the same issue on libreoffice-5-4 branch.

Steps to Reproduce:
1. Open attached ODS with a simple pivot table
2. Refresh the pivot table

Actual Results:  
In G6 cell of the pivot table the "(empty)" value is displayed.

Expected Results:
In G6 cell of the pivot table the "#DIV/0!" string should be displayed.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36
Comment 1 Tamás Zolnai 2017-10-04 20:33:04 UTC
Created attachment 136767 [details]
Simple pivot table with an error item
Comment 2 Commit Notification 2017-10-05 08:36:47 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ee46269003aed237edcd9c086fd14ecded08bbeb

tdf#112884: Error string is displayed as empty item in pivot table

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.