Bug 112901 - Upgrade from 5.2.x 32 bit to 5.3.x 64-bit: Calc is sluggish & fonts are less readable
Summary: Upgrade from 5.2.x 32 bit to 5.3.x 64-bit: Calc is sluggish & fonts are less ...
Status: RESOLVED DUPLICATE of bug 109220
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-05 18:02 UTC by vhatz
Modified: 2017-10-05 18:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vhatz 2017-10-05 18:02:05 UTC
After I updated my LibreOffice from 5.2.x 32-bit to 5.3.x 64-bit Calc has become sluggish. Moving between cells by pressing Ctrl + arrow keys to jump to the next populated cell is not instantaneous like before. Now, it takes about half a second. The same goes when I click to change tab in the same document, or scroll up or down the document. All these operations were very quick in 5.2.x 32-bit. 

Another thing I noticed is that the fonts have changed somehow, although I cannot describe exactly what it is. It is as if they are "pointier", with pixels protruding instead of having smooth lines. This make the smaller fonts a bit less readable.
Comment 1 V Stuart Foote 2017-10-05 18:16:15 UTC
Should be ready for the final 5.3 release.

Please test with the 5.3.7dev build, from here:
http://dev-builds.libreoffice.org/daily/libreoffice-5-3/Win-x86@62-TDF/current/

or for 64-bit here:
http://dev-builds.libreoffice.org/daily/libreoffice-5-3/Win-x86_64@62-TDF/current/

*** This bug has been marked as a duplicate of bug 109220 ***
Comment 2 vhatz 2017-10-05 18:20:55 UTC
Thank you for the quick feedback. Will 5.3.7 version also address the font issue?
Comment 3 V Stuart Foote 2017-10-05 18:28:41 UTC
(In reply to vhatz from comment #2)
> Thank you for the quick feedback. Will 5.3.7 version also address the font
> issue?

It does, basically rolling back some of the work for transition to MS DirectWrite Direct2D font rendering to restore some use of legacy MS GDI rendering. Going forward at 5.4 and 6.0 we'll continue to tweak things so there will likely be some regression again.
Comment 4 vhatz 2017-10-05 18:53:26 UTC
Thank you! :)