Bug 112979 - Applying a template style and formatting to a large file is slower as it has been before
Summary: Applying a template style and formatting to a large file is slower as it has ...
Status: RESOLVED DUPLICATE of bug 112989
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2017-10-07 16:27 UTC by Telesto
Modified: 2017-10-29 17:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (2.91 KB, text/plain)
2017-10-07 16:30 UTC, Telesto
Details
Example file (129.55 KB, application/vnd.oasis.opendocument.text)
2017-10-07 18:10 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-10-07 16:27:19 UTC
Description:
Applying a template style and formatting to a large file is slower as it has been before

Steps to Reproduce:
1. Open the attached file
2. Disable spell checking 
3. Open the sidebar -> Styles and scroll to the bottom
4. Select all (CTRL+A)
5. Wait until the background processing is done (CPU usage should be around 0%)
5. Apply Untitled1 & monitor the CPU usage en count the time needed to apply 


Actual Results:  
With Libo6 -> 18 seconds
With LibO5.3 -> Around 18 seconds
With LibO5.2.5 -> 9 seconds

Expected Results:
Similar to results to LibO5.2.5


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in:
Version: 6.0.0.0.alpha0+
Build ID: c5a93cad149618bbd43632f1660a558c34bdbf7e
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-07_01:04:25
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2017-10-07 16:30:07 UTC
Created attachment 136834 [details]
Bibisect log

I bibisected it to

author	Khaled Hosny <khaledhosny@eglug.org>	2016-11-02 21:52:06 (GMT)
committer	Khaled Hosny <khaledhosny@eglug.org>	2016-11-03 00:17:06 (GMT)
commit	8f2dd1df1d6cc94ebbc1149de72bc6d6dffa6533 (patch)
tree	db496889434c484a87b13ffcc4650d65e6672129
parent	c8be45889217c555e4bec92af838d0524ceba4e0 (diff)
Revert "Revert "Enable the new text layout engine by default""
This reverts commit 3950166877bf1308f9e449992e20b558342af825.

A conformation of that would be nice. A mistake could be possible
Comment 2 Telesto 2017-10-07 18:10:57 UTC
Created attachment 136837 [details]
Example file
Comment 3 Xisco Faulí 2017-10-18 11:40:40 UTC
I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: 5ea1b4c336d1cad92dc18e7cf7e4b381396f448b
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Only win ?
Comment 4 Telesto 2017-10-29 17:06:07 UTC

*** This bug has been marked as a duplicate of bug 112989 ***