Bug 113076 - Italic set fonts are clipped on right edge in presentation mode with OpenGL rendering (HA or CPU rendering not affected)
Summary: Italic set fonts are clipped on right edge in presentation mode with OpenGL r...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.4.2.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords:
: 123302 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2017-10-12 17:15 UTC by V Stuart Foote
Modified: 2019-04-29 09:49 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Manual stretch, bugdoc. (9.97 KB, application/vnd.oasis.opendocument.text)
2019-04-24 15:12 UTC, Miklos Vajna
Details
Manual stretch, screenshot. (102.60 KB, image/png)
2019-04-24 15:13 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2017-10-12 17:15:04 UTC
With OpenGL rendering enabled, Impress presentation of attachment 136926 [details] (from bug 113068) clips the right edge glyphs in textboxes when set italic. The Glyphs are not clipped when italic direct formatting is removed. Wider glyphs (the Comic Sans MS font set italic in slide 4) are also clipped in the presenters view.

With HA, or CPU only rendering the italic glyphs are not clipped on presentation canvas.


=-testing-=
Windows 10 Ent 64-bit en-US with nVidia Quadro K2000
Version: 5.4.2.1 (x64)
Build ID: dfa67a98bede79c671438308dc9036d50465d2cb
CPU threads: 8; OS: Windows 6.19; UI render: GL; 
Locale: en-US (en_US); Calc: group

Version: 6.0.0.0.alpha0+ (x64)
Build ID: 38f9bb33dd6ef4870a71440cf6a86caf5576eaef
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-10-12_01:44:44
Locale: en-US (en_US); Calc: CL
Comment 1 V Stuart Foote 2017-10-12 18:14:41 UTC
This is different from the zoom related issue with OpenGL rendering of bug 112385 where just the last character in a string is affected.  Here it is any italic glyph in a string that leans out of its calculated inkbox and is clipped.
Comment 2 QA Administrators 2018-10-18 02:49:50 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2019-03-21 10:31:25 UTC
*** Bug 123302 has been marked as a duplicate of this bug. ***
Comment 4 Miklos Vajna 2019-04-17 15:17:20 UTC
I can reproduce this (actually not this, but bug 123302). I'll take a look.
Comment 5 Commit Notification 2019-04-23 08:27:02 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/4657335fa5bcbe7980f229ca41ddd82d93c355eb%5E%21

tdf#113076 vcl windows opengl: specific italic set font was clipped on ...

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Pierre C 2019-04-23 14:55:13 UTC
Nice job !
It would be fine to have this work backported to 6.2 and even to 6.1
Comment 7 Miklos Vajna 2019-04-23 15:52:56 UTC
Let's do that once I figure out how to support horizontally stretched text with DirectWrite. Then the two can be backported together.
Comment 8 Miklos Vajna 2019-04-24 15:12:19 UTC
Created attachment 150977 [details]
Manual stretch, bugdoc.

This is currently broken (since DirectWrite is used for horizontal scale), noticed after pushing the above commit.
Comment 9 Miklos Vajna 2019-04-24 15:13:14 UTC
Created attachment 150978 [details]
Manual stretch, screenshot.

How it looks currently in master. Notice that the glyph is left-aligned, not scaled. The fix is pending CI: <https://gerrit.libreoffice.org/#/c/71245/>.
Comment 10 Commit Notification 2019-04-24 16:41:40 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/51bcbfc88883596fceedfe019e841aab129425c9%5E%21

Related: tdf#113076 vcl win DirectWrite: handle stretched text

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-04-29 09:48:25 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/b97495c5ea1bb6dd6504609d4951ce70b3d5be89%5E%21

tdf#113076 vcl windows opengl: specific italic set font was clipped on ...

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-04-29 09:49:55 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/4266020a78e98d7271e7dca8f5727cd7a419afc6%5E%21

Related: tdf#113076 vcl win DirectWrite: handle stretched text

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.