Bug Hunting Session
Bug 113101 - [Notebookbar][Groupedbar Full] Add check for current resolution of screen and show a warning, if resolution less 1368 px horizontally
Summary: [Notebookbar][Groupedbar Full] Add check for current resolution of screen and...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 109518 (view as bug list)
Depends on:
Blocks: Notebookbar-Groupedbar
  Show dependency treegraph
 
Reported: 2017-10-13 17:27 UTC by Roman Kuznetsov
Modified: 2018-03-24 18:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Groupedbar full in LO Writer 6.0.0.2 (51.05 KB, image/png)
2018-01-17 15:58 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2017-10-13 17:27:42 UTC
Description:
For Notebookbar - Groupedbar Full add check for current resolution of screen and show a warning, if resolution less 1368 px horizontally, that this view don't work correctly,
Because on my display with 1280 px horizontally one right block not displayed. In this block contained items Help and Menu. 

Steps to Reproduce:
1. Enable variant of Notebookbar - Groupedbar Full on screen with resolution less 1368 px horizontally
2. Compare it view with it view on screen with 1366 px and more
3.

Actual Results:  
User don't known that Notebookbar - Groupedbar Full will displayed not fully on his screen and user will be in shock, when will can't go back to default two toolbars view

Expected Results:
User known that Notebookbar - Groupedbar Full will displayed not fully on his screen and will think before activate this view!


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Xisco Faulí 2018-01-17 15:39:12 UTC
Hi kompilainenn,
Could you please add an screenshot to see how the notebookbar is displayed?
Comment 2 Roman Kuznetsov 2018-01-17 15:56:06 UTC
(In reply to Xisco Faulí from comment #1)
> Hi kompilainenn,
> Could you please add an screenshot to see how the notebookbar is displayed?

hmm..now we have the improvement for groupedbar full, that allow display all hidden items if resolution less then need

may be this bug not needs today?
Comment 3 Roman Kuznetsov 2018-01-17 15:58:45 UTC
Created attachment 139154 [details]
Groupedbar full in LO Writer 6.0.0.2
Comment 4 Xisco Faulí 2018-01-17 15:59:26 UTC
it seems correct now. I think we can close it as RESOLVED WORKSFORME
Comment 5 Xisco Faulí 2018-01-19 09:46:56 UTC
*** Bug 109518 has been marked as a duplicate of this bug. ***