Bug 113176 - Font Name "Monospace Regular" is displayed as currently closest installed font while it is not installed.
Summary: Font Name "Monospace Regular" is displayed as currently closest installed fon...
Status: RESOLVED DUPLICATE of bug 61134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Substitution
  Show dependency treegraph
 
Reported: 2017-10-17 09:17 UTC by ricky.tigg
Modified: 2020-10-08 03:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Wrong mention in Font Name about Monospace Regular closest used font. (15.07 KB, image/png)
2017-10-17 09:17 UTC, ricky.tigg
Details
Wrong mention in Font Name about Monospace Regular closest used font. (78.65 KB, image/png)
2017-10-17 09:21 UTC, ricky.tigg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ricky.tigg 2017-10-17 09:17:59 UTC
Created attachment 137039 [details]
Wrong mention in Font Name about Monospace Regular closest used font.

default font– for selection. That font is also required in document in order to copy past from document to terminal without corruption, so that the pasted content is identical to the copied source content.

By adding that missing font in Writer as follow: View → Styles and Formatting (F11) → then by right-clicking the active style → Modify… → Then enter manually ”Monospace Regular” → OK. The information ”This font has not been installed. The closest available font will be used.” is displayed in the same window in question on attachment.

Nevertheless in the document, when the cursor has for location target a character formatted with the created new font, Writer displays "Monospace Regular" as Font Name, which is confusing; Indeed the editor makes no mention about what might be in reality the closest font.
Comment 1 ricky.tigg 2017-10-17 09:21:03 UTC
Created attachment 137040 [details]
Wrong mention in Font Name about Monospace Regular closest used font.
Comment 2 Dieter 2017-10-17 18:33:08 UTC
I confirm this bug. the only difference is, that only "Monospace" is displayed, but it is Monospace Regular

Version: 5.4.2.2 (x64)
Build-ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU-Threads: 4; Betriebssystem:Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 3 Yousuf Philips (jay) (retired) 2017-10-18 20:02:29 UTC
Hi Ricky Tigg,

Thank you for reporting this bug, but it has been reported before.

*** This bug has been marked as a duplicate of bug 61134 ***