Bug Hunting Session
Bug 113399 - DOT IMPORT, DOCX EXPORT: Page number not shown correctly
Summary: DOT IMPORT, DOCX EXPORT: Page number not shown correctly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:6.1.0 target:6.0.0.2
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-10-24 13:02 UTC by Patrick Jaap
Modified: 2018-01-04 09:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
minimal file with a page number (72.00 KB, application/msword-template)
2017-10-24 13:03 UTC, Patrick Jaap
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Jaap 2017-10-24 13:02:50 UTC
Description:
Opening the attached doc-template (dot) file with Writer and saving it to docx hides the page number. The text box seems to be too small.

Steps to Reproduce:
1. Open minimal.dot in Writer
2. Save it as docx-file.
3. Open the docx-file in Writer

Actual Results:  
Page number is hidden by a too small text box.

Expected Results:
Page number is shown completely.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Patrick Jaap 2017-10-24 13:03:19 UTC
Created attachment 137248 [details]
minimal file with a page number
Comment 2 Xisco Faulí 2017-10-24 20:17:18 UTC
Regression introduced by c761df1e42fd11acc5fc05b0baacd803c3788ca6 which is the same commit as in bug 109229
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 109229 ***
Comment 3 Tamás Zolnai 2017-12-27 15:44:53 UTC
It's not a duplicate
Comment 4 Commit Notification 2017-12-27 19:22:13 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=89bd93fc1a5277f4e7ffcea74d4087b63736ae97

tdf#113399: DOT IMPORT, DOCX EXPORT: Page number not shown correctly

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Patrick Jaap 2018-01-02 13:52:40 UTC
I can confirm this bug is fixed, thanks!
Comment 6 Oliver Sander 2018-01-02 13:55:04 UTC
Thanks also from me!  Can this please be backported to the 6.0 branch?
Comment 7 Commit Notification 2018-01-04 09:07:30 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=83e9a46615089de6979c950a2b62e0464e93e486&h=libreoffice-6-0

tdf#113399: DOT IMPORT, DOCX EXPORT: Page number not shown correctly

It will be available in 6.0.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.