Bug 113429 - Paste special - Text only, still pastes direct text formatting
Summary: Paste special - Text only, still pastes direct text formatting
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL: https://help.libreoffice.org/6.2/bs/t...
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Direct-Formatting-Parts Paste-Special-Unformatted
  Show dependency treegraph
 
Reported: 2017-10-25 06:39 UTC by Dan Dascalescu
Modified: 2018-11-20 12:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Copy the cell (note the portion in red) (10.42 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-10-25 06:40 UTC, Dan Dascalescu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Dascalescu 2017-10-25 06:39:28 UTC
Description:
I expect that pasting special, Text only, would only paste the text, without ANY formatting. However, if I copy to the clipboard a cell that has one word colored red, that formatting will be pasted even if "Formats" is unchecked in the Paste Special dialog.

Steps to Reproduce:
1. Open the attached file
2. Copy cell A1
3. Paste Special into a new file, checking only "Text" (make sure "Formats" is unchecked)

Actual Results:  
The colored word is pasted

Expected Results:
Only the text should be pasted, without any formatting


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36
Comment 1 Dan Dascalescu 2017-10-25 06:40:09 UTC
Created attachment 137275 [details]
Copy the cell (note the portion in red)
Comment 2 m.a.riosv 2017-10-25 22:36:32 UTC
Reproducible, maybe because the format it's part of the text format not the cell format.

Version: 5.4.3.1 (x64)
Build ID: 32c8895c6cae21571f364dbb059f419a743ee44d
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: es-ES (es_ES); Calc: group
Comment 3 QA Administrators 2018-10-27 02:55:01 UTC Comment hidden (obsolete)
Comment 4 Timur 2018-11-20 12:04:49 UTC
I change the title to indicate that "Paste special - Text only, still pastes direct text formatting".
But that looks like NotABug because you indeed paste text, but with it's formatting. 
Moreover, you can use Paste Unformatted Text to paste a simple unformatted text.
So I find it appropriate to close. 
What I conclude from this bug and Bug 121452 is that we lack good help pages on this, or I didn't find them in https://help.libreoffice.org/6.2/bs/text/scalc/guide/main.html.