Bug Hunting Session
Bug 113542 - LibreOffice 5.4.2.2 Crashes when Tools > Options > LibreOffice > View is selected
Summary: LibreOffice 5.4.2.2 Crashes when Tools > Options > LibreOffice > View is sele...
Status: RESOLVED DUPLICATE of bug 108406
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-31 02:03 UTC by Sezen
Modified: 2017-10-31 06:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sezen 2017-10-31 02:03:02 UTC
Description:
All LibreOffice 5.4.2.2 applications running on Linux Mint 18.2 Sarah are crashing when Tools > Options > LibreOffice > View is selected regardless selecting by mouse or by up/down arrow keys.
I can select other options and they are shown properly in the popup window but it comes to view, it crashes ans immediately closes the popup configuration window. This happens on all LibreOffice applications ( Writer, Calc, etc...) in a same way.

Steps to Reproduce:
1.Open any LibreOffice application (Writer, Calc, Impress etc...)
2. Goto to Tools > Options. Popup configuration window appears
3. Select the LibreOffice > view option either by mouse or by arrow down key
4. It crashes immediately when the View is selected.

Actual Results:  
It crashes, popup configuration window disappears and libre office processes die.

Expected Results:
It should have not crashed. It should have shown the view configuration options


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 5.4.2.2
Build ID: 1:5.4.2~rc2-0ubuntu0.16.04.1~lo2
CPU threads: 4; OS: Linux 4.11; UI render: default; VCL: x11; 
Locale: en-CA (en_CA.UTF-8); Calc: group

===========================================================================
Can't check if OpenGL is enabled, because it craches on selecting the View from the Options.
How to enable/disable OpenGL

Go to Tools ▸ Options ▸ LibreOffice ▸ View and check/uncheck Use OpenGL for all rendering
===============================================================================

Same thing happened in Safe mode, too, it crashed again. I did the same in safe mode and it crashed again .

LibreOffice 5.3 and newer

    start LibreOffice and select Help > Restart in Safe Mode...
    if your problem is that LibreOffice does not start at all, launch it from the command line with the parameter --safe-mode
    in the 'Enter Safe Mode' dialog select 'Restart'
    LibreOffice will restart and display the 'Safe Mode' dialog
    select Continue in safe mode
==============================================================================


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Xisco Faulí 2017-10-31 06:53:29 UTC

*** This bug has been marked as a duplicate of bug 108406 ***