Bug 113555 - Last "zero" will be ignored
Summary: Last "zero" will be ignored
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CSV-Export
  Show dependency treegraph
 
Reported: 2017-10-31 18:05 UTC by unknown
Modified: 2017-12-13 18:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
saved with 5.3.6 (230.68 KB, text/csv)
2017-11-13 17:37 UTC, unknown
Details
saved with 5.4.2.2 (272.50 KB, text/csv)
2017-11-13 17:38 UTC, unknown
Details
first dataset, all ok, site1 (135.71 KB, image/jpeg)
2017-11-13 17:38 UTC, unknown
Details
first dataset, all ok, site2 (181.02 KB, image/jpeg)
2017-11-13 17:39 UTC, unknown
Details
first dataset, zeros ignored, site1 (135.22 KB, image/jpeg)
2017-11-13 17:39 UTC, unknown
Details
first dataset, zeros ignored, site2 (179.70 KB, image/jpeg)
2017-11-13 17:40 UTC, unknown
Details
save options (35.67 KB, image/jpeg)
2017-11-13 17:48 UTC, unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description unknown 2017-10-31 18:05:20 UTC
Description:
Hi,

first, i will write my bug in two languages, because i'm german and my english isn't so good to explain. Thanks!

english version:
Libreoffice calc v5.4 (stable version) is showing the last zero of a number (of a currency), but if i import the csv-files in a management-software, the last number (of zero) will be ignored.
examples: 15,60 will be 1,56, 1347,80 -> 134,78 and 1342,10 -> 134,21.

With libreoffice calc 5.3.6 and excel too, all it's great!

PS: I do it month ago, so i'm not the problem!


german version:
In LibreOffice Calc 5.4 ("Stable" also aktuelle Version) werden die letzten Nullen, in einer erstellten csv-Datei, zwar angezeigt, doch beim Import in die Warenwirtschaft (WaWi) wird diese Null ignoriert. Dabei ist es egal ob das 15,60, 134,70 oder z.B. 1342,10 sind.
Aus den Zahlen 15,60, 1347,80 und 1342,10 wird dann 1,56, 134,78 und 134,21.
Dann sind falsche Zahlen in der Warenwirtschaft hinterlegt!

Mit LibreOffice v5.3.6 und auch Excel ist alles bestens!

PS: Ich mache das schon einige Monate, also liegt es definitiv nicht an mir!

Steps to Reproduce:
you can't, because in libreoffice the numbers are shown good, but after import into management-software the numbers are bad!

Actual Results:  
....

Expected Results:
....


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Dennis Roczek 2017-10-31 20:08:53 UTC
Hi CSV,

bitte füge doch noch einmal deine ODS Datei und die generiete CSV Datei hinzu, damit wir probieren können, dein problem nachzustellen.
Danke

Dennis

(Please add the ODS + generated CSV to test)
Comment 2 unknown 2017-11-01 10:16:29 UTC
I don't have a .ods.
The .csv will saved from a .xlsx.

To create a .csv with the problems i've to install libreoffice 5.4.2 at work again.
I don't have a file (with the problem) yet.
This and next week i can't install v5.4.2.x.

Eine .ods-Datei habe ich nicht.
Die .csv wird ausgehend von einer .xlsx erzeugt.

Um eine .csv mit dem Problem zu erstellen, muss ich erst wieder LibreOffice 5.4.2.x auf der Arbeit installieren.
Habe nämlich keine Datei aufgehoben.
Diese und nächste Woche kann ich das leider auf der Arbeit auch nicht machen.
Comment 3 Dennis Roczek 2017-11-01 14:37:16 UTC
Hi CSV,

bitte hänge mal irgendeine Datei als Beispiel dran, also eine ODS, CSV oder auch XSLX. Ansonsten können wir dir leider nicht weiterhelfen. (Gerne auch die Daten manipulieren, sodass die Daten anonymisiert sind.)

short EN:
please attach ANY file as an example. 


Dennis
Comment 4 unknown 2017-11-03 15:21:39 UTC
To do this i've to install libreoffice 5.4 at work again, then open a .xlsx or another file and save it with v5.4, for like i said, i can't install v5.4 this or next week!

Um irgendeine Datei anzuhängen, muss ich auf der Arbeit erst wieder LibreOffice 5.4 installieren und die .xlsx etc. damit öffnen, bearbeiten und speichern, was ich diese und nächste Woche nicht machen kann.
Ich habe keine Datei mehr die mit v5.4 gespeichert wurde!
Comment 5 Dennis Roczek 2017-11-11 13:33:41 UTC
you might want to use the portableApps version from https://www.libreoffice.org/download/portable-versions/
Comment 6 unknown 2017-11-13 17:37:34 UTC
Created attachment 137709 [details]
saved with 5.3.6
Comment 7 unknown 2017-11-13 17:38:01 UTC
Created attachment 137710 [details]
saved with 5.4.2.2
Comment 8 unknown 2017-11-13 17:38:39 UTC
Created attachment 137711 [details]
first dataset, all ok, site1
Comment 9 unknown 2017-11-13 17:39:10 UTC
Created attachment 137712 [details]
first dataset, all ok, site2
Comment 10 unknown 2017-11-13 17:39:52 UTC
Created attachment 137713 [details]
first dataset, zeros ignored, site1
Comment 11 unknown 2017-11-13 17:40:16 UTC
Created attachment 137714 [details]
first dataset, zeros ignored, site2
Comment 12 unknown 2017-11-13 17:48:18 UTC
Created attachment 137716 [details]
save options
Comment 13 unknown 2017-11-13 17:49:48 UTC
german:
So, heute die zwei CSV-Dateien erzeugt. Einmal mit LibreCalc 5.3.6 und einmal mit 5.4.2.2.

Gespeichert wurden beide Dateien mit denselben Optionen (Optionen.jpg)

Die Bilder zeigen das Problem!
Die Bilder zeigen nur den ersten Datensatz, da dort ja schon das Problem besteht!
Nach dem Import in die Warenwirtschaft werden bei der mit 5.3.6 erzeugten CSV die Nullen angezeigt, bei der mit 5.4.2.2 werden sie dagegen ignoriert und zeigen somit falsche Preise an.



english:
Today i have 2 csv-files saved with LibreCalc. One with 5.4.2.2 and the other one with 5.3.6.

I have saved both with the same options (picture Optionen.jpg).

The pcitures shows the problem.
The pictures shows only the first data, because there is the problem too.
After importing in to the management-software (blue background).
The one with 5.3.6 is ok, the one with 5.4.2.2 is bad (with ignored zeros)!
Comment 14 Dennis Roczek 2017-11-13 19:48:59 UTC
Super. Thanks. 

well it is still a valid sales price just leaving out the ending nulls. Actually this is not our bug!

But the solution is rather simple. go to column "M" (as an example) -- right cick on it; format cells --> choose a currency format and export it again: the nulls will be saved in the CSV.
Comment 15 unknown 2017-11-14 17:34:40 UTC
The cells formatted right!
It will be saved in the csv, but after import there are the differents and the problem!
Comment 16 unknown 2017-11-14 17:41:00 UTC
Ich mache das nicht erst seit gestern, dass ich solche Dateien erstelle!
Ich weiß also genau wie ich was formatieren muss und es wird ja auch in der CSV-Datei gespeichert. 

Nur nachdem ich es in der Warenwirtschaft importiert habe, wird es falsch angezeigt.
Deshalb ja auch noch einmal beide Dateien die ich gestern angehängt habe.

Es ist also definitiv ein Bug!!!
Auch wenn ihr es nicht anderweitig prüfen könnt.
Comment 17 Eike Rathke 2017-11-14 17:47:38 UTC
Format those price columns with 0,00 (do not use a currency format as otherwise your "Warenwirtschaft" will probably be confused by the currency symbol) and make sure that when exporting you check "Edit filter settings" and within there "Save cell content as shown" (however those might be named in a German version).

This is NOTABUG ot at least NOTOURBUG.
Comment 18 Dennis Roczek 2017-11-14 17:50:28 UTC
(german discussion)
hi unkown,

also: wenn ich die CSV, welche du angehangen hast, mit LibreOffice 5.4 "richtig formatiere", dann speichere, dann werden "nullen" angehangen.

Wenn das Warenwirtschaftssystem unfähig ist, Kommata richtig zu interpretieren, dann ist diesem leider nicht geholfen. (btw: Ich mache beruflich Anpassungen für Microsoft Dynamics NAV: um welches handelt es sich denn hier bei dir?)

Schau dir bitte die CSV mal im Text-Editor an. Da siehst du, dass die Komma enthalten sind. Wenn ein Programm das nicht importieren kann, dann stelle bitte bei diesem Hersteller ein Ticket.

Außerdem habe ich ein WORKAROUND geliefert!

(eine ursprüngliche XLS(X) die wir gefordert hatten, auch anonymisiert gab es ja leider nicht)
Comment 19 unknown 2017-11-14 18:09:39 UTC
Das Warenwirtschaftssystem ist Carladata, das kennst du/ihr bestimmt nicht.

Laut WaWi-Support müssen die Preise als Zahl formatiert werden.
Mache ich ja auch (mit 2 Nachkommastellen).
Ich mache das ja schon lange, zuletzt erfolgreich mit Libre 5.3.6. 
Nur Libre 5.4.2.2 macht die Probleme.

Eike Rathke's letzten englischen Kommentar habe ich nicht richtig verstanden.
Ich soll die Spalte als "0,00" formatieren, also ein Benutzerdefiniertes Format?
Und beim Export (also Speichern?) soll ich wo was kontrollieren?

Ich frage mich halt nur, wenn es mit 5.3.6 funktioniert, so wie ich es immer gemacht habe und es dann mit 5.4.2.2 nicht mehr funktioniert, dann kann es ja nicht an dem liegen wie ich vorgehe bzw. was ich mache!
Comment 20 unknown 2017-11-14 18:11:11 UTC
Die XLS(X) kann ich nachliefern!
Comment 21 Eike Rathke 2017-11-14 18:18:19 UTC
(In reply to unknown from comment #19)
> Eike Rathke's letzten englischen Kommentar habe ich nicht richtig verstanden.
> Ich soll die Spalte als "0,00" formatieren, also ein Benutzerdefiniertes
> Format?
> Und beim Export (also Speichern?) soll ich wo was kontrollieren?
> 
> Ich frage mich halt nur, wenn es mit 5.3.6 funktioniert, so wie ich es immer
> gemacht habe und es dann mit 5.4.2.2 nicht mehr funktioniert, dann kann es
> ja nicht an dem liegen wie ich vorgehe bzw. was ich mache!
Doch kann es, wenn du in 5.4.2 im "Textdatei exportieren" Dialog nicht "Zellinhalt wie angezeigt speichern" angehakt hast. Und 0,00 ist kein benutzerdefiniertes sondern ein vordefiniertes Format.
Comment 22 unknown 2017-12-13 18:58:45 UTC
Also.... ich hatte v5.4 vor 2-3 Wochen erneut installiert und musste einmal den Haken bei "Zellinhalt wie angezeigt speichern" setzen, der war wohl nicht bei der Installation von Haus aus gesetzt?!

Daraufhin funktionierte es mehrmals ohne Probleme :-), bis plötzlich alle Zahlen - in der Vorschau der WaWi - nur noch in der ersten Zeile standen. :-/ *wunder*
Quasi alle VK's (auch der EK) waren - in der Vorschau der WaWi - plötzlich in der Zeile "Verkaufspreis-2" hintereinander gestanden.
Da mir das alles zuviel Arbeitszeit kostete, hatte ich dann wieder v5.3.6 installiert und seit dem ist wieder Ruhe.

Also irgendwas scheint da nicht wirklich ausgereift zu sein in v5.4, aber sei wie es will, ich bleibe bei v5.3.6 so lange es geht!

Im übrigen kann und darf ich die Excel-Vorlage mit allen Inhalten nicht weitergeben - Info von Oben -, die hatten wir damals zur WaWi dazukaufen müssen, sonst wäre der Import so nicht möglich.