Bug 113599 - calc hangs when dealing with too many comments
Summary: calc hangs when dealing with too many comments
Status: RESOLVED DUPLICATE of bug 76324
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks: Calc-Comments
  Show dependency treegraph
 
Reported: 2017-11-02 13:09 UTC by A M
Modified: 2019-06-06 07:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A M 2017-11-02 13:09:27 UTC
dear all. How to reproduce.
------------ 1st method
1) open a new calc document
2) add a comment to the first cell (any text will do)
3) copy that cell
4) select a large part of the sheet , say 10 rows x 100 columns
5) paste
result: libreoffice will start using 100% CPU and hang for more time than I am willing to wait.
-------------
info: I am using the package  LibreOffice_5.4.2_Linux_x86-64_deb.tar.gz downloaded from the official website and installed in Debian stretch
----
thanks
Comment 1 A M 2017-11-02 13:11:45 UTC
there is a similar bug report 60418, but that one 
- is about Writer and not Calc,
- is about a specific document, that contains some specific problems
so I do not think that this is a duplicate bug.
Comment 2 Xisco Faulí 2017-11-02 13:23:15 UTC
Reproduced in

Version: 6.0.0.0.alpha1+
Build ID: 1f8c3e3b78e0abb96d06a51eca354ae7ade5deb2
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and all the way back to 

 LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 QA Administrators 2018-11-03 03:49:32 UTC Comment hidden (obsolete)
Comment 4 b. 2019-05-30 18:19:26 UTC
in response to Comment #3: 

yes: it is! a bug, 

yes: it is still in the program in ver: 

Version: 6.3.0.0.alpha1+ (x64)
Build ID: 63b39fe87644587210214198fb67d6b3fb3343c5
CPU threads: 8; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-27_03:06:43
Locale: de-DE (de_DE); UI-Language: en-US
Calc: *unthreaded* 

yes: imho it's a clear duplicate of 76324, 

yes: i'd like the importance raised, it's monstering around for more than 5 years now, 

yes: i tested AOO 4.1.6, it has similar problems, performing much better with a big number of comments - 30k?, but crash when expanding to 90k. 

as - in many comments - assorted as 'inherited from OO', perhaps an idea to form a combined team?
Comment 5 Timur 2019-06-06 07:33:45 UTC

*** This bug has been marked as a duplicate of bug 76324 ***