Bug Hunting Session
Bug 113619 - CRASH when export PDF from Print Preview
Summary: CRASH when export PDF from Print Preview
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: highest critical
Assignee: Ashod Nakashian
URL:
Whiteboard: target:6.0.0
Keywords: bibisected, bisected, needUITest, regression
Depends on:
Blocks:
 
Reported: 2017-11-03 08:38 UTC by Telesto
Modified: 2018-02-01 17:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-11-03 08:38:37 UTC
Description:
CRASH when export PDF from Print Preview

Steps to Reproduce:
1. Open attachment 136841 [details]
2. Toggle to print Preview
3. Click Export as PDF button
4. use default settings and save and define the location for storing -> Press Save

Actual Results:  
Crash

Expected Results:
No Crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.0.0.alpha1+
Build ID: 13c5dd1d98a480cb01ca8f24242c80e326e4ade8
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-30_23:52:07
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Xisco Faulí 2017-11-03 10:46:54 UTC
Regression introduced by:

author	Ashod Nakashian <ashod.nakashian@collabora.co.uk>	2017-09-25 01:51:13 (GMT)
committer	Ashod Nakashian <ashnakash@gmail.com>	2017-09-26 11:58:52 (GMT)
commit	3823697d99b28592d8923e099b6aab577d5cd339 (patch)
tree	f99cf1e273e7f231d04272f0f55ae31e6f7f4c8e
parent	cfb355ec205044234840405fde4343898c2ea97b (diff)
TSCP: refactor paragraph metadata field check
This moves the logic into SwEditShell next to
the exiting paragraph metadata infrastructure.

Bisected with: bibisect-linux64-6.0

Adding Cc: to Ashod Nakashian
Comment 2 Ashod Nakashian 2017-11-03 10:52:28 UTC
Taking this one.
Comment 3 Ashod Nakashian 2017-11-03 12:06:51 UTC
Fix on gerrit: https://gerrit.libreoffice.org/#/c/44259/
Comment 4 Julien Nabet 2017-11-03 17:04:41 UTC
Let's put this one to ASSIGNED since Ashod assigned himself.
Comment 5 Commit Notification 2017-11-07 05:19:16 UTC
Ashod Nakashian committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8c4b480e85bbafb7b914377a3e279f6982ff9044

tdf#113619 prevent cores when there is no cursor

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Michael Meeks 2017-11-07 10:35:21 UTC
Ash - is this fixed; can we close ? =)
Comment 7 Xisco Faulí 2017-11-08 07:54:30 UTC
Crash no longer reproducible in

Version: 6.0.0.0.alpha1+
Build ID: 5e0022c90c4125a1590b3688dfec73c271b7aedd
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Ashod Nakashian,
Please close this issue as RESOLVED FIXED once your work is done here.