Bug 113642 - Narad hindi font preview in font drop down is incorrect
Summary: Narad hindi font preview in font drop down is incorrect
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Name-Combobox
  Show dependency treegraph
 
Reported: 2017-11-04 11:26 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-12-03 15:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (40.74 KB, image/png)
2017-11-04 11:26 UTC, Yousuf Philips (jay) (retired)
Details
Sample doc with font used. (7.95 KB, application/vnd.oasis.opendocument.text)
2017-11-30 18:58 UTC, G Karunakar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-11-04 11:26:53 UTC
Created attachment 137517 [details]
screenshot

So its incorrectly rendering the 'Narad' name with the font and doesnt show a font sample on the right.
Comment 1 G Karunakar 2017-11-30 05:31:26 UTC
Please give a link where to get the font.
Comment 2 Yousuf Philips (jay) (retired) 2017-11-30 08:03:40 UTC
You can download the font here

http://fontsgeek.com/fonts/Narad-Regular
Comment 3 G Karunakar 2017-11-30 18:31:12 UTC
This font is not a Devanagari Opentype font. Its Latin-1 encoded with devanagari glyphs, or custom encoded one. 
Not to be used for Devanagari based languages on LibreOffice.

What is seen in preview is glyphs encoded for letters in 'Narad'. So for the font preview is correct.
Comment 4 G Karunakar 2017-11-30 18:53:24 UTC
Recommend to close this bug, resolved - notourbug/notabug
Comment 5 G Karunakar 2017-11-30 18:58:13 UTC
Created attachment 138156 [details]
Sample doc with font used.

Sample text with two lines containing 'Narad' . Second line has Narad font applied. Same gets shown in font preview.

Have a glyph map from fontforge but not attaching since might raise copyright issue.
Comment 6 Yousuf Philips (jay) (retired) 2017-12-02 12:40:41 UTC
(In reply to G Karunakar from comment #3)
> This font is not a Devanagari Opentype font. Its Latin-1 encoded with
> devanagari glyphs, or custom encoded one. 
> Not to be used for Devanagari based languages on LibreOffice.

Many symbol fonts also use Latin-1 to place its glyphs in it, so we dont show the font name encoded with the glyphs.

Khaled, Stuart: thoughts?
Comment 7 V Stuart Foote 2017-12-02 14:38:11 UTC
Yes but this is a seriously broken font. It is not suited for use as Unicode with no coverage of Devangari (0970-097f, A8E0-A8ff), just questionable encoding on Basic Latin/Latin-1 supplement. It is not even a proper symbol font, just glyphs incorrectly assigned. 

There is nothing we can do correctly or otherwise with this font. Nor can any other Unicode based program.

=> NOTABUG
Comment 8 Khaled Hosny 2017-12-03 15:15:20 UTC
Agreed, not a bug.