Bug 113643 - Editing tables in Impress lags terribly
Summary: Editing tables in Impress lags terribly
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords: bibisected, bisected, perf
Depends on:
Blocks:
 
Reported: 2017-11-04 12:43 UTC by E Moen
Modified: 2018-11-10 20:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Impress file with table (30.12 KB, application/vnd.oasis.opendocument.presentation)
2017-11-04 12:44 UTC, E Moen
Details
Bibisect log (2.91 KB, text/plain)
2017-11-04 19:28 UTC, Telesto
Details
Impress file with table (19.54 KB, application/vnd.oasis.opendocument.presentation)
2018-11-09 21:35 UTC, E Moen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description E Moen 2017-11-04 12:43:48 UTC
Description:
In general Impress is a laggy part of the suite. Where it becomes almost unusable is when a populated table is edited. The typing lags so much I exceed the pace the program showing letters and words. I have tried every setting I can possibly think of (Hardware acceleration, Open GL, Memory settings, Experimental features, Java, a fresh user profile et cetera).

I hope this is not considdered normal. Ever since version 5, Impress is laggy and It seems to become worse with every release.

In Writer, working with tables is painless. So why is it so terrible in Impress?

Steps to Reproduce:
1.After opening the attached Impress file, start typing text in the table.
2.
3.

Actual Results:  
Laggy performance

Expected Results:
Smooth typing.


Reproducible: Always


User Profile Reset: Yes



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36 OPR/48.0.2685.52
Comment 1 E Moen 2017-11-04 12:44:24 UTC
Created attachment 137518 [details]
Impress file with table
Comment 2 Telesto 2017-11-04 19:25:25 UTC
Confirming with:
Version: 6.0.0.0.alpha1+
Build ID: 06cad1a9a42ea74434f9ed0e4027163d029eb4a1
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-11-02_23:40:06
Locale: nl-NL (nl_NL); Calc: CL

Steps to reproduce
1. Open attachment 137518 [details]
2. Start typing text in the table on sheet 2
3. Scroll up/down
Comment 3 Telesto 2017-11-04 19:28:18 UTC
Created attachment 137523 [details]
Bibisect log

Bisected to:
author	Noel Grandin <noel@peralex.com>	2015-11-10 12:51:47 (GMT)
committer	Noel Grandin <noel@peralex.com>	2015-11-10 13:30:03 (GMT)
commit	05b9c892b8568b076a6bc14f45c889e7cd5385ca (patch)
tree	8192abd6d0d5d61df8b6d416975e9571a94dbb50
parent	c1cd376c2830f626ebfde9585b9ddb93ce603b48 (diff)
editeng: boost::ptr_vector->std::vector<std::unique_ptr>
Comment 4 Telesto 2017-11-04 19:30:05 UTC
Duplicate of bug 108608

*** This bug has been marked as a duplicate of bug 108608 ***
Comment 5 Noel Grandin 2018-04-24 06:38:44 UTC
Could someone try out the patch in
    https://gerrit.libreoffice.org/53371 
and see if it helps them, seems to work for me
Comment 6 Buovjaga 2018-04-24 06:59:43 UTC
(In reply to Telesto from comment #2)
> Confirming with:
> Version: 6.0.0.0.alpha1+
> Build ID: 06cad1a9a42ea74434f9ed0e4027163d029eb4a1
> CPU threads: 4; OS: Windows 6.3; UI render: default; 
> TinderBox: Win-x86@42, Branch:master, Time: 2017-11-02_23:40:06
> Locale: nl-NL (nl_NL); Calc: CL
> 
> Steps to reproduce
> 1. Open attachment 137518 [details]
> 2. Start typing text in the table on sheet 2
> 3. Scroll up/down

Is this Windows-only? I don't see a problem even in 6.0.3. If so, I am unable to test Noel's patch as I don't have a Win build env set up.
Comment 7 Commit Notification 2018-04-26 06:48:59 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=13a1bc409d9b2f0d14f4d316b7977b1fc2eb3c8a

tdf#113643 Editing tables in Impress lags terribly

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Buovjaga 2018-04-26 20:03:20 UTC
In Windows I am able to repro with 6.0.3, but 6.1 alpha1 does not have the terrible lag

Version: 6.1.0.0.alpha1 (x64)
Build ID: cb47f0d320994e001bc38dc2ee9b7d957b15e6ab
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: fi-FI (fi_FI); Calc: group
Comment 9 E Moen 2018-11-09 21:35:15 UTC
Created attachment 146513 [details]
Impress file with table

In the current stable version:

Versie: 6.0.6.2 (x64)
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-threads: 4; Besturingssysteem: Windows 10.0; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: group

typing lag is a bit less in this version. However working with tables (selecting text, putting the cursor to type, selecting another cell than the current, etc.) is extremely laggy.

Try the attached file.
Comment 10 Buovjaga 2018-11-09 21:36:22 UTC
(In reply to E Moen from comment #9)
> Created attachment 146513 [details]
> Impress file with table
> 
> In the current stable version:
> 
> Versie: 6.0.6.2 (x64)
> Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
> CPU-threads: 4; Besturingssysteem: Windows 10.0; UI-render: standaard; 
> Locale: nl-NL (nl_NL); Calc: group

Nope, try with 6.1.3.
Comment 11 E Moen 2018-11-10 20:04:42 UTC
Running 6.1.3.2 and the improvement is impressive! Lag is as good as gone. Guess I'll be using the fresh branche now. Thanks a lot.