Bug 113656 - Embedding of unused fonts then 'Embed fonts in the document' option is checked
Summary: Embedding of unused fonts then 'Embed fonts in the document' option is checked
Status: RESOLVED DUPLICATE of bug 65353
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Embedded
  Show dependency treegraph
 
Reported: 2017-11-05 09:40 UTC by Timur Davletshin
Modified: 2017-11-06 22:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example test document (77 bytes, text/plain)
2017-11-05 09:44 UTC, Timur Davletshin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur Davletshin 2017-11-05 09:40:20 UTC
Description:
Unused CJK fonts get inside of text documents with embedded fonts, which creates huge documents.

Steps to Reproduce:
1. Create new text document
2. Check File -> Properties -> Fonts -> 'Embed fonts in the document'
3. Save file

Actual Results:  
This creates huge file (more than 20 Mb) with unused CJK fonts inside.

Expected Results:
Embed only fonts defined in Styles or used via direct formatting.


Reproducible: Always


User Profile Reset: Yes



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Timur Davletshin 2017-11-05 09:44:27 UTC
Created attachment 137532 [details]
Example test document
Comment 2 Telesto 2017-11-06 09:14:57 UTC
Repro with:
Versie: 4.2.0.4 
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba7
Comment 3 Dieter 2017-11-06 22:00:19 UTC
Downloaded the (empty) document => 25 MB

11 Embedded fonts:
Microsoft YaHei bold => 9,4 MB
Microsoft YaHei UI => 13,8 MB
AR PL Sungtil GB => 2,3 MB

I opened styles.xml => the three fonts mentioned above are used in styles. So it's the expected result I would say.
Comment 4 Maxim Monastirsky 2017-11-06 22:25:16 UTC

*** This bug has been marked as a duplicate of bug 65353 ***