Bug 113658 - Font embedding feature is not working as expected for TTC fonts
Summary: Font embedding feature is not working as expected for TTC fonts
Status: RESOLVED DUPLICATE of bug 83675
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Embedded
  Show dependency treegraph
 
Reported: 2017-11-05 10:08 UTC by Timur Davletshin
Modified: 2017-12-19 14:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example test documents (211 bytes, text/plain)
2017-11-05 10:12 UTC, Timur Davletshin
Details
Broken file with TTC inside (deleted)
2017-11-13 19:06 UTC, Timur Davletshin
Details
Vegur font as TTC (zipped) (28.30 KB, application/zip)
2017-12-09 17:04 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur Davletshin 2017-11-05 10:08:38 UTC
Description:
Multiple copies of the same font created inside ODT file structure (Fonts folder) or totally wrong fonts are embedded.

Steps to Reproduce:
1. Create new text document
2. Specify non-standard TTC font via direct formatting and write something
3. Save document
4. Uncompress created document as ZIP archive and check Fonts folder

Actual Results:  
With some fonts I get multiple copies of the same font (e.g. Optima) or totally wrong fonts embedded (Didot instead of Hoefler Text).

Expected Results:
Embed only files used in document


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Maybe linked with https://bugs.documentfoundation.org/show_bug.cgi?id=113656


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Timur Davletshin 2017-11-05 10:12:30 UTC Comment hidden (obsolete)
Comment 2 Dieter 2017-11-05 20:51:31 UTC Comment hidden (obsolete)
Comment 3 Dieter 2017-11-05 20:53:12 UTC Comment hidden (obsolete)
Comment 4 Dieter 2017-11-05 21:07:38 UTC Comment hidden (obsolete)
Comment 5 Timur Davletshin 2017-11-05 21:24:54 UTC Comment hidden (obsolete)
Comment 6 Dieter 2017-11-06 21:52:37 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2017-11-13 18:16:18 UTC
Could you please provide a TTC file that is free to distribute so it can be tested?

Information copied from your text file:

https://drive.google.com/file/d/0Bxs_utDd2nQgQTBMaEhQblM2Q1k/view?usp=sharing — wrong fonts

https://drive.google.com/file/d/0Bxs_utDd2nQgS0p6NTRjeDZLcVk/view?usp=sharing — multiple copies of the same font
Comment 8 Timur Davletshin 2017-11-13 19:05:04 UTC
AFAIK, none of the fonts listed in Wikipedia as free are available in TTC file format. Fonts used in mentioned documents come from Mac OS X which I use in dual boot with Linux.
Comment 9 Timur Davletshin 2017-11-13 19:06:32 UTC Comment hidden (obsolete)
Comment 10 Timur Davletshin 2017-11-13 19:08:30 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2017-12-09 17:00:00 UTC Comment hidden (obsolete)
Comment 12 Buovjaga 2017-12-09 17:04:34 UTC
Created attachment 138331 [details]
Vegur font as TTC (zipped)

I generated a .ttc from Vegur Regular, Light and Bold, which is used in LibreOffice branding. I used these instructions: https://confluence.atlassian.com/confkb/how-to-create-ttc-family-font-file-773981523.html

Could you please test with this file?

I had to zip it because Bugzilla does not allow .ttc
Comment 13 Timur Davletshin 2017-12-19 11:56:20 UTC
(In reply to Buovjaga from comment #12)
> Created attachment 138331 [details]
> Vegur font as TTC (zipped)
> 
> I generated a .ttc from Vegur Regular, Light and Bold, which is used in
> LibreOffice branding. I used these instructions:
> https://confluence.atlassian.com/confkb/how-to-create-ttc-family-font-file-
> 773981523.html
> 
> Could you please test with this file?
> 
> I had to zip it because Bugzilla does not allow .ttc

Still buggy with your font. I made blank document with Vegur Regular font (installed in ~/.fonts) selected manually. Saved document has Vegur Bold embedded twice and no Regular.
Comment 14 Buovjaga 2017-12-19 14:06:38 UTC
I tested on Windows with no previous Vegur, I installed my TTC. Then: File - Properties - Font - Embed fonts in this document.
I used Vegur Regular.

In the zip there were 15 .ttf files, of which 2 Windows said they were not valid font files. There were .ttfs for every variant of Arial and Liberation Sans (bold, italic etc.). None of the .ttfs I could open were Vegur.

I think we can call this a duplicate of 83675

tested with
Version: 6.1.0.0.alpha0+ (x64)
Build ID: 0bb0299b29960c3a27427eba5d5fc34e5e913a8b
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-12-09_00:15:04
Locale: fi-FI (fi_FI); Calc: group threaded

*** This bug has been marked as a duplicate of bug 83675 ***