Bug 113665 - Visual bug with spelling check turned on
Summary: Visual bug with spelling check turned on
Status: RESOLVED DUPLICATE of bug 103322
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: All Windows (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-05 21:45 UTC by horus
Modified: 2019-05-29 14:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file containing the issue (9.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-11-05 21:46 UTC, horus
Details
Image showing what I have on screen (7.85 KB, image/png)
2017-11-05 21:47 UTC, horus
Details
What happens with and without spelling check -- the characters are moved (533.15 KB, video/avi)
2017-12-27 20:00 UTC, horus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description horus 2017-11-05 21:45:41 UTC
Description:
I've just found a visual bug when the following conditions are met:
1. Spelling check is turned on
2. Zoom is 100%
3. Arial font is used

And I only have this bug with the particular character string "Kiwi, Fresh'ins"

I'll upload two files: one ODS file containing the issue and one PNG file showing the visual problem.

Steps to Reproduce:
1. Open the sample file
2. Make sure spelling check is ON
3. Make sure zoom is at 100%

Actual Results:  
There's an extra spacing between the letter s and the letter h

Expected Results:
No extra spacing


Reproducible: Always


User Profile Reset: No



Additional Info:
Locale: en-US
Module: SpreadsheetDocument
OS: Windows 10
OS is 64bit: Yes


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 horus 2017-11-05 21:46:35 UTC
Created attachment 137544 [details]
Sample file containing the issue
Comment 2 horus 2017-11-05 21:47:05 UTC
Created attachment 137545 [details]
Image showing what I have on screen
Comment 3 Xavier Van Wijmeersch 2017-11-06 09:28:19 UTC
Can not reproduce using sample with

Version: 6.0.0.0.alpha1+
Build ID: 6070dec9ca9a15587a2aece81f9ae1ab5ac0f8c4
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-11-05_00:08:31
Locale: nl-BE (en_US.UTF-8); Calc: group

maybe only windows
Comment 4 Timur 2017-11-10 16:00:00 UTC
I see it in Windows with older LO and previous 6.0+.
Can't see with latest 6.0 alpha, could be some bug on spelling or ongoing work.
Some characters look wider with spell checking.
I won't confirm this, looks really trivial, maybe NeedDevEval.
Comment 5 Johnny_M 2017-11-10 20:05:52 UTC
This could be another incarnation of bug 88991 and/or bug 72546, with the root cause being bug 103322 or an old version of the Arial font. Visual impact severity might depend on screen resolution or Arial font (i.e. Windows) version. I can't confirm in with LO 5.3.6.1 Portable on Win10 64-bit, Full HD.
Comment 6 Buovjaga 2017-11-14 19:31:29 UTC
horus: maybe try with a fresh master build (6.0): http://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/
If you need some other dictionary than en-US you have to install it for 6.0.
Comment 7 horus 2017-12-27 19:59:25 UTC
(In reply to Xavier Van Wijmeersch from comment #3)
> Can not reproduce using sample with
> [deleted]
> maybe only windows

Me too.  I also think it's only in Windows because of Arial font.  That's why I conservatively marked "Windows" platform only.
_____

(In reply to Buovjaga from comment #6)
> horus: maybe try with a fresh master build (6.0):
> http://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/
> If you need some other dictionary than en-US you have to install it for 6.0.

OK, I've tried a master build, not 6.0 but 6.1.
The setup is:
libo-master64~2017-12-25_23.59.08_LibreOfficeDev_6.1.0.0.alpha0_Win_x64.msi

And I installed it in a freshly new Win 10 (64bit).  It took me some time to find out how to enable spelling check because of lack of dictionary.  Once enabled, the problem is unfortunately still there.  I've made a video to show you the difference.  In the video, I pressed Shift+F7 to switch between spelling check and without.
Comment 8 horus 2017-12-27 20:00:55 UTC
Created attachment 138697 [details]
What happens with and without spelling check -- the characters are moved
Comment 9 Telesto 2017-12-28 18:42:33 UTC
Repro with
Version: 6.1.0.0.alpha0+
Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-26_23:10:23
Locale: nl-NL (nl_NL); Calc: CL

and with
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

It isn't font specific as far I can tell.. bug 103322 sounds reasonable to be
Comment 10 Buovjaga 2017-12-28 19:00:31 UTC
Let's take a chance on bug 103322.

*** This bug has been marked as a duplicate of bug 103322 ***
Comment 11 horus 2018-02-08 11:30:45 UTC
(In reply to Telesto from comment #9)
> [delete]
> 
> It isn't font specific as far I can tell.. bug 103322 sounds reasonable to be

Yeah, I also noticed that the text with the other font (Liberation Sans) also moved.  Do I need to redo the test with "master build 6.1" in the original PC where I found this bug?  Or is the bug totally confirmed?
Comment 12 horus 2019-05-29 14:49:57 UTC
According to bug 103322, a patch was committed to fix the integer/floating point issue for that bug.

I have tried the following daily builds but the problem described in this bug is still present:
* libo-master64~2019-05-22_00.57.02_LibreOfficeDev_6.3.0.0.alpha1_Win_x64.msi
* libo-master64~2019-05-29_09.41.50_LibreOfficeDev_6.3.0.0.alpha1_Win_x64.msi
* master~2019-05-24_22.08.51_LibreOfficeDev_6.3.0.0.alpha1_Win_x64_en-US_de_ar_ja_ru_vec_qtz.msi
* master~2019-05-29_04.28.58_LibreOfficeDev_6.3.0.0.alpha1_Win_x64_en-US_de_ar_ja_ru_vec_qtz.msi

Also note that the problem also happens at other zoom levels:
80%, 90%, 110%, 140%

So, maybe this bug has nothing to do with bug 103322?