Bug Hunting Session
Bug 113681 - Auto correction for German(Switzerland) should not replace 'ss' by 'ß'
Summary: Auto correction for German(Switzerland) should not replace 'ss' by 'ß'
Status: RESOLVED DUPLICATE of bug 103156
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-06 17:25 UTC by Michael
Modified: 2017-11-06 19:34 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2017-11-06 17:25:54 UTC
Description:
In switzerland the german special character 'ß' ('long s') is never used, it does not exist. All occurences of 'ß' are replaced by 'ss'.

Especially there are the following replacement rules, which should be disabled for German (switzerland):
- Gruss -> Gruß
- Grüsse -> Grüße

Both of them (any maybe more) make your text wrong as you type. In general one would say, that all rules, which contain an 'ß' on the right hand side should be inverted to contain the 'ß' on the left side (and 'ss' on the right side) or at least they should be disabled.

Not sure with which version it started. Probably this is also affects other platforms.

All of the said above also comes true for German (Liechtenstein).

Steps to Reproduce:
1. Set localization for auto correction to Deutsch (Schweiz) / German (Switzerland)
2. Type the words Gruss and Grüsse

Actual Results:  
They are replaced by Gruß and Grüße.

Expected Results:
They should not be replaced by Gruß and Grüße.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Comment 1 Julien Nabet 2017-11-06 19:34:24 UTC

*** This bug has been marked as a duplicate of bug 103156 ***