Bug Hunting Session
Bug 113689 - Spreadsheets containing a chart immediately marked as modified after opening them
Summary: Spreadsheets containing a chart immediately marked as modified after opening ...
Status: CLOSED DUPLICATE of bug 31231
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-07 10:48 UTC by Gumersindo
Modified: 2017-11-07 13:53 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Spreadsheet with no chart. It behaves as expected. (12.10 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-11-07 10:52 UTC, Gumersindo
Details
Same spreadsheet, with a chart. It behaves incorrectly. (21.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-11-07 10:53 UTC, Gumersindo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gumersindo 2017-11-07 10:48:59 UTC
Description:
Any spreadsheet containing at least a chart of any type is marked as modified right after being opened by Calc. I.e. the Save icon has a star above it, and if I try to close the document I get a 'Save Document?' pop-up.

I started detecting this bug ever since I updated from v5.4.1 to v5.4.2.

Steps to Reproduce:
1.Open a spreadsheet that doesn't contain a chart
2.Create a chart in it
3.Save it, close it, and open it again

Actual Results:  
Right after opening it, and before I do anything to it, the document is marked as modified.

Expected Results:
The document shouldn't be marked as modified until I do any actual modification to it.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Gumersindo 2017-11-07 10:52:01 UTC
Created attachment 137590 [details]
Spreadsheet with no chart. It behaves as expected.

I've created this document with LO Calc 4.2.8.2 as I don't have access to my home PC (with LO 5.4.2.2) right now.
Comment 2 Gumersindo 2017-11-07 10:53:48 UTC
Created attachment 137591 [details]
Same spreadsheet, with a chart. It behaves incorrectly.

I've created this document with LO Calc 4.2.8.2 as I don't have access to my home PC (with LO 5.4.2.2) right now, but the result should be the one described in the bug report.
Comment 3 Gumersindo 2017-11-07 10:56:24 UTC
Forgot to mention that this looks like a recurrent issue, re-appearing every now and then as can be seen in the comments for bug 31231
Comment 4 Eike Rathke 2017-11-07 13:52:46 UTC
Should be fixed with http://cgit.freedesktop.org/libreoffice/core/commit/?id=f657454b69c813b90a8b3c1adb2feef1066dbd35 see bug 31231.
Though this bug here is a new incarnation and maybe not the same cause, the other bug has the details, cause and fix listed, hence marking this as duplicate.

*** This bug has been marked as a duplicate of bug 31231 ***