Bug Hunting Session
Bug 113708 - Pasting multiple lines at start of line corrupts undo history (Reverses to last line pasted)
Summary: Pasting multiple lines at start of line corrupts undo history (Reverses to la...
Status: RESOLVED DUPLICATE of bug 115088
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Undo-Redo Paste-Special-Unformatted
  Show dependency treegraph
 
Reported: 2017-11-08 00:15 UTC by Kieran Grant
Modified: 2018-02-09 15:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kieran Grant 2017-11-08 00:15:50 UTC
Description:
(Only appears to affect Writer)
When pasting multiple lines of text at the start of a line containing text, the old line is appended to the first pasted line, and the other lines follow after. If I try to undo, it leaves the last pasted line. (Undo history is corrupted).
I can redo to restore the combined lines and manually remove pasted text.
Text must be either pasted as "Unformatted Text" or copied from another program.

Steps to Reproduce:
1. In a new document type "Some line here" (without quotes)
2. Copy from another text editor (or Libre Document) the following lines:
line 1
line 2
line 3
3. Past these lines to start of the line in step 1 (if copied from Libre, past as "Unformatted Text")
4. Undo

Actual Results:  
line 3

Expected Results:
Some line here


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 5.4.2.2 (x64)
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-AU (en_AU); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Dieter Praas 2017-11-08 07:01:59 UTC
Tried to repdrocue the bug

...

3a) Paste as unformatted text

Result:
line 1Some line here
line 2
line 3
line 1
line 2
line 3

4. Undo

Result:
line 3
line 1
line 2
line 3

=> I confirm your bug

3b) Paste

Result:
line 1
line 2
line 3Some line here
line 1
line 2
line 3

=> I also think that, paste as unformatted text produces a wrong result.
Comment 2 Kieran Grant 2017-11-08 08:08:01 UTC
I agree about paste being incorrect, I thought that at the time when I originally pasted it, I think that is why I tried undoing in the first place... then I get interested by the result of undoing...

Logically the original line should be on the end of the last pasted line.
Comment 3 Kevin Suo 2018-02-09 15:21:42 UTC
This should be a duplicate of Bug 111349. Feel free to set back to new if I am wrong.

*** This bug has been marked as a duplicate of bug 111349 ***
Comment 4 Kevin Suo 2018-02-09 15:30:45 UTC

*** This bug has been marked as a duplicate of bug 115088 ***