Download it now!
Bug 113742 - FILEOPEN: DOCX: Frames not placed correctly
Summary: FILEOPEN: DOCX: Frames not placed correctly
Status: RESOLVED DUPLICATE of bug 123651
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Frames
  Show dependency treegraph
 
Reported: 2017-11-09 17:21 UTC by Frederic Parrenin
Modified: 2019-08-06 12:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
.docx file to reproduce the problem (645.61 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-11-09 17:21 UTC, Frederic Parrenin
Details
comparison MSO 2010 and LibreOffice 6.0 (180.79 KB, image/png)
2017-11-09 23:28 UTC, Xisco Faulí
Details
LibreOffice 5.0 (153.67 KB, image/png)
2017-11-09 23:33 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2017-11-09 17:21:24 UTC
Created attachment 137647 [details]
.docx file to reproduce the problem

Steps to reproduce:
- open the attached file in Writer
- open it in MS Word
- compare
=> the two frames placed in the left margin are not placed correctly in Writer.
Comment 1 Xisco Faulí 2017-11-09 23:28:01 UTC
Created attachment 137651 [details]
comparison MSO 2010 and LibreOffice 6.0
Comment 2 Xisco Faulí 2017-11-09 23:33:17 UTC
it seems it was much better in

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

than in

Version: 6.0.0.0.alpha1+
Build ID: f5765d9f621bdc8fd0e1ac5eec1dcab9ae5b5d06
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: th-TH (ca_ES.UTF-8); Calc: group

or

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 3 Xisco Faulí 2017-11-09 23:33:38 UTC
Created attachment 137652 [details]
LibreOffice 5.0
Comment 4 Aron Budea 2017-11-10 18:12:42 UTC
Buggy in 5.2.0.4, ok in 5.1.0.3, adjusting version.
Comment 5 Aron Budea 2017-11-11 05:13:14 UTC
Bibisected to the following commit using bibisect-win32-5.2. Adding Cc: to Miklos Vajna, please take a look sometimes.

Same commit as for bug 109851, but the repro steps are somewhat different, so let's not close it as duplicate yet.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=50223ea6e212b60b7d33839c2753c5601fb50f95
author		Miklos Vajna <vmiklos@collabora.co.uk>	2016-03-31 13:05:48 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-03-31 17:49:00 (GMT)

tdf#98987 sw: add AddVerticalFrameOffsets compat mode
Comment 6 QA Administrators 2018-11-12 03:41:05 UTC Comment hidden (obsolete)
Comment 7 Roman Kuznetsov 2018-11-12 09:11:37 UTC
still repro in

Version: 6.2.0.0.alpha1+
Build ID: 6896f39ffd8a6c4b32b8f601a6a93678247456bd
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-11-05_22:40:18
Locale: ru-RU (ru_RU); Calc: threaded
Comment 8 Xisco Faulí 2019-01-30 11:47:13 UTC
Still reproducible in

Version: 6.3.0.0.alpha0+
Build ID: f1f84cf7fae3c777908cfc5357a067db731367ac
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 Miklos Vajna 2019-08-06 12:07:57 UTC
This looks good on master, turns out my 27894be916d5d03ee820e757d2f4abbf21d54615 fix for bug 123651 helped here, as well.

*** This bug has been marked as a duplicate of bug 123651 ***