Bug Hunting Session
Bug 113744 - Very choppy, slow scrolling above a certain speed
Summary: Very choppy, slow scrolling above a certain speed
Status: RESOLVED DUPLICATE of bug 113347
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-09 18:36 UTC by Joel Lisenby
Modified: 2017-11-09 19:04 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
The csv file used in video screen capture demo of slow scrolling bug. (10.96 KB, text/plain)
2017-11-09 18:39 UTC, Joel Lisenby
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Lisenby 2017-11-09 18:36:08 UTC
Choppy scrolling above a certain speed. Please see video screen capture: https://youtu.be/4QlD9reW4f8

System: Windows 10 Pro, Build 16299.19 with latest updates installed.
CPU: Intel i7 6700
RAM: 16GB
GPU: AMD RX480, Radeon Software Version 17.11.1
Java: Libreoffice built-in java runtime -- no external java runtime installed.

This is a very small 11kb, 150 line document with only 3 columns with not too much data in each cell and no embedded graphics, yet it is very unresponsive to scrolling at a faster pace. Is there anything that can be done to make scrolling smooth? It's been this way as long as I can remember using libreoffice calc and I figured I would try submit a report now. A smooth UI would make using libreoffice calc a more enjoyable experience.
Comment 1 Joel Lisenby 2017-11-09 18:39:18 UTC
Created attachment 137649 [details]
The csv file used in video screen capture demo of slow scrolling bug.
Comment 2 Mike Kaganski 2017-11-09 18:54:21 UTC
I'm sure it's the duplicate; but in case I made a mistake, please reset to unconfirmed.

FYI: there's no "Libreoffice built-in java runtime" - if you have no Java in system, there'll be no Java functionality.

Also: please don't forget to post the data from LibreOffice's Help-About dialog. If you will reopen, then make sure you do.

*** This bug has been marked as a duplicate of bug 113347 ***
Comment 3 Joel Lisenby 2017-11-09 18:59:11 UTC
Oops, my misunderstanding on the JRE part! Thanks, here is the about info:

Version: 5.4.2.2 (x64)
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU threads: 8; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: CL
Comment 4 Mike Kaganski 2017-11-09 19:04:34 UTC
Or may be bug 108703.