Bug Hunting Session
Bug 113773 - Creating or Updating an Alphabetical Index causes Writer to crash
Summary: Creating or Updating an Alphabetical Index causes Writer to crash
Status: RESOLVED DUPLICATE of bug 113284
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-11 17:33 UTC by Jean-Francois Nifenecker
Modified: 2017-11-11 20:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Francois Nifenecker 2017-11-11 17:33:52 UTC
Description:
When updating an existing alphabetical index, Writer crashes with an error : 
vector::_M_range_check
Trying to create an alphabetical index causes the same error (see the steps to reproduce).

Steps to Reproduce:
To reproduce with a new index:
1. Open a Writer session
2. Insert some text into a new document (eg: the Lorem autotext)
3. Save it
4. Select successively some words within the document, then using the menu Insert > Table of Contents and Index > Index entry
add a few entries into a new alphabetical index (the entries background is grayed ok)
5. Save
6. Place the cursor at the end of the document and add a new paragraph
7. Menu Insert > Table of Contents and Index > Table Of contents, Index or Bibliography
8. On the Type tab, "Type" option, select "Alphabetical index"
9. OK

An error message is displayed:
Fatal Error
vector::_M_range_check
[OK]
LibreOffice crashes.

Actual Results:  
Crash

Expected Results:
Alphabetical index created.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 5.4.3.2
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 4; OS: Linux 3.16; UI render: default; VCL: gtk2; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

OpenGL
glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.3.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.3.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.3.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0
OpenGL ES profile extensions:



User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Julien Nabet 2017-11-11 20:41:38 UTC

*** This bug has been marked as a duplicate of bug 113284 ***