Bug 113822 - FILEOPEN: PPTX: Underline animation does nothing
Summary: FILEOPEN: PPTX: Underline animation does nothing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: PPTX Custom-Animations
  Show dependency treegraph
 
Reported: 2017-11-14 10:43 UTC by Xisco Faulí
Modified: 2018-09-17 05:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
underline (33.64 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-11-14 10:43 UTC, Xisco Faulí
Details
doesnt work (1.64 MB, video/mp4)
2018-09-16 14:41 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-11-14 10:43:13 UTC
Created attachment 137744 [details]
underline

Steps to reproduce:
1. Open attached document
2. Pres F5

Observed behaviour: Nothing happens

Reproduced in

Version: 6.0.0.0.alpha1+
Build ID: a7f961ddd88df4117de5f7c199881cf75d2905b5
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: th-TH (ca_ES.UTF-8); Calc: group

and

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Mohamed 2017-11-15 08:58:36 UTC
The issue is reproduced on :
    • Operating system : Windows 8.1 Pro 64-bits.
    • LibreOffice : Version: 5.4.3.1 (x64)
      Build ID: 32c8895c6cae21571f364dbb059f419a743ee44d
      CPU threads: 4; OS: Windows 6.29; UI render: default; 
      Locale: en-US (en_US); Calc: group

And also on :
    • Operating system : Ubuntu 16.04.3 64-bits.
    • LibreOffice :Version: 5.4.3.1
      Build ID: 32c8895c6cae21571f364dbb059f419a743ee44d
      CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
      Locale: ja-JP (ja_JP.UTF-8); Calc: group
Comment 2 Commit Notification 2018-07-18 00:27:15 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=daafe79c55cd53decbeac2367f298d79371dcf3d

tdf#113822 convert animation value in SetTimeNodeContext.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2018-08-06 13:16:41 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a472d3352a61b51624aea480410789e3f547a9ca

tdf#113822 handle letter-by-letter animations in pptx documents.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 BogdanB 2018-09-16 14:41:53 UTC
Created attachment 144908 [details]
doesnt work

I tested on linux on 6.2. and it doesnt work. I attached a video showing that nothing happened, but third times I push also F5 and after that, when nothing happened I push space and a line was moving to the right... But it is only when pusing "space" button fromkeyboard.

Version: 6.2.0.0.alpha0+
Build ID: e005ab5d40d358adb75a64e140d46f4bf605647d
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-15_02:08:38
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 5 BogdanB 2018-09-17 05:11:36 UTC
I made a mistake, I suposed that presentation starts by itself. It should be started eith space, or click. 

So, YES, this bug is SOLVED.