Bug Hunting Session
Bug 113823 - Tools > Options > Justification - wrong preview for Left/Right justification
Summary: Tools > Options > Justification - wrong preview for Left/Right justification
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2017-11-14 11:57 UTC by Omer Zak
Modified: 2018-09-17 20:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Format > Paragraph... > Justification dialog showing the problem (37.80 KB, image/png)
2017-11-14 11:59 UTC, Omer Zak
Details
no reproducible (44.00 KB, image/png)
2017-11-14 12:27 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Omer Zak 2017-11-14 11:57:29 UTC
Description:
Open LibreOffice with Hebrew UI and CTL enabled for Hebrew.
Format > Paragraph... > Justification

The previews for Left Justification and Right Justification are opposite relative to what they should have been.

Steps to Reproduce:
1. Set LibreOffice to Hebrew UI
2. Enable CTL for Hebrew
3. Format > Paragraph... > Justification

Actual Results:  
Preview shows wrong justification when Left or Right justifications are selected.

Expected Results:
Preview shows correct justification.


Reproducible: Didn't try


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.75 Safari/537.36
Comment 1 Omer Zak 2017-11-14 11:59:49 UTC
Created attachment 137746 [details]
Format > Paragraph... > Justification dialog showing the problem

In this screenshot, right justification was selected, yet the preview shows left justification.
Comment 2 Xisco Faulí 2017-11-14 12:27:17 UTC
Created attachment 137747 [details]
no reproducible

I can't reproduce it in

Version: 6.0.0.0.alpha1+
Build ID: 9050854c35c389466923f0224a36572d36cd471a
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: th-TH (ca_ES.UTF-8); Calc: group

using SAL_RTL_ENABLED=1
Comment 3 Xisco Faulí 2017-11-14 12:28:41 UTC
In your screenshot, justification is set to right, it should be set to left...
Comment 4 Omer Zak 2017-11-14 12:55:05 UTC
When I set justification to left, the preview shows right justification.
I did not add a screenshot for this case as well.

By the way, this bug is similar to https://bugs.documentfoundation.org/show_bug.cgi?id=107567 (which reports wrong preview in the Indents & Spacing tab).
Comment 5 Yousuf Philips (jay) (retired) 2017-11-15 22:24:27 UTC
Yes i can repo it with arabic UI, but this will likely be resolved when bug 107567 is fixed.
Comment 6 Eyal Rozenberg 2018-09-17 20:45:09 UTC
I'm not seeing this bug with:

Version: 6.1.1.2
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); Calc: group threaded

Based on the last comment, marking as fixed - but feel very free to reopen if you still set it with v6.1.1.2 or later.