Bug Hunting Session
Bug 113873 - LibreOffice Writer crashes when trying to add an Alphabetical Index
Summary: LibreOffice Writer crashes when trying to add an Alphabetical Index
Status: RESOLVED DUPLICATE of bug 113284
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-16 09:34 UTC by Theo
Modified: 2017-12-06 14:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The runtime crash dialog box. (6.12 KB, image/jpeg)
2017-11-16 09:35 UTC, Theo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Theo 2017-11-16 09:34:11 UTC
Description:
Since LibreOffice 5.4.3.2 I consistently get a runtime error followed by a crash when either I try to insert an Alphabetical Index to a document or try to update an Alphabetical Index in an existing document. This appears to be a regression as I don't have these crashes with 5.4.2.2.
I can get it with both a single new document and with our master documents.

Steps to Reproduce:
1. Open a new writer document
2. Type a sentence "This is an index test."
3. Go to Insert > Table of Contents and Index > Table of Contents, Index or Bibliography.
4. Select from the Type combo box Alphabetical Index.

Actual Results:  
A dialog box is shown with the title "LibreOffice 5.4 - Fatal Error" and the text
"invalid vector<T> subscript" is shown.

Expected Results:
Be able to click OK to insert the Alphabetical Index.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Versie: 5.4.3.2
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU-threads: 4; Besturingssysteem:Windows 6.1; UI-render: GL; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Theo 2017-11-16 09:35:58 UTC
Created attachment 137801 [details]
The runtime crash dialog box.
Comment 2 Xisco Faulí 2017-11-16 10:33:38 UTC
Confirmed in

Versión: 5.4.3.2
Id. de compilación: 92a7159f7e4af62137622921e809f8546db437e5
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group

but not in

Version: 5.4.2.2
Build ID: 1:5.4.2~rc2-0ubuntu0.17.04.1~lo2
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: x11; 
Locale: es-ES (ca_ES.UTF-8); Calc: group

WIN only
Comment 3 Xisco Faulí 2017-11-16 10:36:17 UTC
Actually I can't reproduce it in

Version: 6.0.0.0.alpha1+
Build ID: fe7384f7d6539210d46b31f9bde64129088be32b
CPU threads: 1; OS: Windows 6.1; UI render: default; 
Locale: es-ES (es_ES); Calc: group

Could you please try with a daily build from http://dev-builds.libreoffice.org/daily/master/ ?

Closing as RESOLVED WORKSFORME. Please, feel free to reopen it if it's still reproducible in a master build
Comment 4 Theo 2017-11-16 10:53:59 UTC
Unfortunately it still crashes with the same runtime error. I used

Versie: 6.0.0.0.alpha1 
Build ID: c1d1f859b268f650143d48f294999cda0fa57350
CPU-threads: 4; Besturingssysteem:Windows 6.1; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL

Note: I have disabled OpenGL to see if that effected the issue, but this bug does not appear to be caused by OpenGL.
Comment 5 Theo 2017-11-16 11:03:19 UTC
Apparently I got the wrong alpha1+. I now used this one (Win-x86@42, Branch:master, Time: 2017-11-06_23:18:19) and I can confirm that this version does not crash.

Versie: 6.0.0.0.alpha1+ 
Build ID: a5af0fd9f27af42cf2e8571f659cdad6e606215b
CPU-threads: 4; Besturingssysteem:Windows 6.1; UI-render: standaard; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-11-06_23:18:19
Locale: nl-NL (nl_NL); Calc: CL
Comment 6 Xisco Faulí 2017-11-16 11:20:45 UTC
(In reply to Theo from comment #5)
> Apparently I got the wrong alpha1+. I now used this one (Win-x86@42,
> Branch:master, Time: 2017-11-06_23:18:19) and I can confirm that this
> version does not crash.
> 
> Versie: 6.0.0.0.alpha1+ 
> Build ID: a5af0fd9f27af42cf2e8571f659cdad6e606215b
> CPU-threads: 4; Besturingssysteem:Windows 6.1; UI-render: standaard; 
> TinderBox: Win-x86@42, Branch:master, Time: 2017-11-06_23:18:19
> Locale: nl-NL (nl_NL); Calc: CL

Thanks for retesting... Closing as RESOLVED WORKSFORME

@raal, would you mind checking when it was fixed?
Comment 7 Aron Budea 2017-11-17 02:04:50 UTC
Fixed by the commit in bug 113284:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=090e9ecd0960e6027cfaaf4600e95dc311524143

*** This bug has been marked as a duplicate of bug 113284 ***
Comment 8 Theo 2017-12-06 14:53:45 UTC
I can confirm that it has been fixed in:
Versie: 5.4.4.1
Build ID: da790616461e15a10c95a80eb8ef8ee7b726c114
CPU-threads: 4; Besturingssysteem:Windows 6.1; UI-render: GL; 
Locale: nl-NL (nl_NL); Calc: CL