Bug 113878 - Copy/Paste of partial cell contents string with hyperlink - nothing happens or, in recent versions, string with link appears _twice_
Summary: Copy/Paste of partial cell contents string with hyperlink - nothing happens o...
Status: RESOLVED DUPLICATE of bug 115317
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2017-11-16 12:51 UTC by Rainer Bielefeld Retired
Modified: 2018-10-27 20:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document for STR (9.61 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-11-16 12:51 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2017-11-16 12:51:31 UTC
Created attachment 137808 [details]
Sample Document for STR

Steps how to reproduce with Version: 5.4.2.2 Build-ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4 CPU-Threads: 4; Betriebssystem:Windows 6.1; UI-Render: Standard; Gebietsschema: de-DE (de_DE); Calc: group

1. Open attached sample document
2. Double click cell A1
3. select string "hyperlink" (from left to right, using only mouse)
4. rightclick selection → copy
5. Doubleclick cell A3 → past
   Expected: string with link pasted
   Actual: Nothing                                                        :-(

Additional info:
a) 'Paste Special → Text RTF' will not work, either
b) 'Paste Special → Plain Text' works fine
c) copy/paste of complete cell works fine
Comment 1 Rainer Bielefeld Retired 2017-11-16 12:53:14 UTC
d) no obvious DUPs found with <https://bugs.documentfoundation.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=DUPs113878&sharer_id=19321>
Comment 2 raal 2017-11-17 12:05:08 UTC
I can not confirm with Version: 6.0.0.0.alpha1+
Build ID: a7cd63df37144eba8544f6b10b83737fa0496461
CPU threads: 4; OS: Windows 6.1; UI render: default; 

Seems to be fixed with dev version. Please could you test it with dev version?  You can download it here: http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 3 Rainer Bielefeld Retired 2017-11-17 12:53:27 UTC
(In reply to raal from comment #2)

With server installation of Version: 6.0.0.0.alpha1+ 
Build ID: a5af0fd9f27af42cf2e8571f659cdad6e606215b CPU threads: 4; 
OS: Windows 6.1; UI render: default; TinderBox: Win-x86@42, Branch:master, 
Time: 2017-11-06_23:18:19
Locale: de-DE (de_DE); Calc: CL

I see some changes in behavior, but it's still not ok:

Step
5.   » No visible effect                                                  :-(
5.1. <Enter>
     » Now string with link appears _twice_
Comment 4 raal 2017-11-17 14:16:58 UTC
(In reply to Rainer Bielefeld Retired from comment #3)
> (In reply to raal from comment #2)
> 
> 
> I see some changes in behavior, but it's still not ok:
> 
> Step
> 5.   » No visible effect                                                  :-(
> 5.1. <Enter>
>      » Now string with link appears _twice_

Confirm
Comment 5 Buovjaga 2018-03-12 19:41:17 UTC
Repro in 5.3.0 alpha1, but not in 4.4.7 (on Win).

Also repro on Linux.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: de53d4690d25b9f1bbc0def6c66ce5b45b2fdc96
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 12th 2018
Comment 6 Buovjaga 2018-06-02 15:22:21 UTC
Bisecting points to the same blamed commit as for bug 115317.
Bug 106386 is also caused by the commit.

*** This bug has been marked as a duplicate of bug 115317 ***