Bug Hunting Session
Bug 113900 - Equations are mixed after reopening odt document
Summary: Equations are mixed after reopening odt document
Status: RESOLVED DUPLICATE of bug 99225
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formula-Editor
  Show dependency treegraph
 
Reported: 2017-11-17 11:17 UTC by Gyula Tóth
Modified: 2017-12-02 18:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of bad math objects (42.38 KB, image/png)
2017-11-17 11:19 UTC, Gyula Tóth
Details
another screenshot of bad math (52.80 KB, image/png)
2017-11-17 11:20 UTC, Gyula Tóth
Details
Example document showing the bug (214.79 KB, application/vnd.oasis.opendocument.text)
2017-11-20 09:38 UTC, Gyula Tóth
Details
Example file now working (205.49 KB, application/vnd.oasis.opendocument.text)
2017-11-20 10:03 UTC, Buovjaga
Details
Second example document showing the bug (733.14 KB, application/vnd.oasis.opendocument.text)
2017-11-20 10:39 UTC, Gyula Tóth
Details
Second example PDF showing how formulas in document should look like (574.18 KB, application/pdf)
2017-11-20 10:46 UTC, Gyula Tóth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gyula Tóth 2017-11-17 11:17:54 UTC
Description:
LibreOffice Math equations appear mixed and distorted after reopening an odt document with lots of math equations.

Steps to Reproduce:
1. Create a document with lots of equations
2. Save
3. Re-open saved document

Actual Results:  
Some of the equations as objects are mixed and appear at the wrong place, hence distorted (too wide or too tall or too short). I can send screenshots.

Expected Results:
Equations should not be mixed and should appear correctly.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 Gyula Tóth 2017-11-17 11:19:28 UTC
Created attachment 137826 [details]
screenshot of bad math objects
Comment 2 Gyula Tóth 2017-11-17 11:20:07 UTC
Created attachment 137827 [details]
another screenshot of bad math
Comment 3 Gyula Tóth 2017-11-17 11:20:40 UTC
It is quite frustrating after a lot of work... :(
Comment 4 Buovjaga 2017-11-17 18:46:12 UTC
(In reply to Gyula Tóth from comment #0)
> OpenGL enabled: Yes

And what if you disable Tools - Options - LibreOffice - View - Use OpenGL for all rendering?
Comment 5 Gyula Tóth 2017-11-20 08:47:07 UTC
I've tried it - disabling OpenGL rendering unfortunately has no effect on the bug.
Comment 6 Buovjaga 2017-11-20 09:27:18 UTC
Please attach an example document.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 7 Gyula Tóth 2017-11-20 09:38:17 UTC
Created attachment 137866 [details]
Example document showing the bug
Comment 8 Buovjaga 2017-11-20 10:03:45 UTC
Created attachment 137869 [details]
Example file now working

I could fix the problem by double-clicking the problematic formulas and exiting the formula editor. When I saved and reloaded, the problem did not return.

I remember seeing a report like this, but I cannot find it.

Can you please try my attached fixed file, if you can make it broken again?

The file is saved from 6.0, but I tried also with 5.4.3 and same good result.

Arch Linux 64-bit
Version: 6.0.0.0.alpha1+
Build ID: 121303615054568c204def97872343d2014af4a0
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 17th 2017
Comment 9 Gyula Tóth 2017-11-20 10:39:27 UTC
Created attachment 137870 [details]
Second example document showing the bug

This is a second example document showing the bug. The actual problem is that the equations are randomly changed at one part of the document with another equation in the same document. Even if you can fix individual equations by double-clicking, they are not restored into their original place. 

The equations in their correct places you can see in the second PDF attachment Example1.pdf
Comment 10 Gyula Tóth 2017-11-20 10:46:33 UTC
Created attachment 137872 [details]
Second example PDF showing how formulas in document should look like

The equations in their correct places you can see in the second PDF attachment Example1.pdf
Comment 11 Gyula Tóth 2017-11-20 10:48:43 UTC
By double clicking the equations can be fixed and I could not make it broken again. However, the equations are still out of place. Please look at the second example.
Comment 12 Buovjaga 2017-11-20 13:03:20 UTC
Ah, sheer luck brought the right bug into my inbox!

*** This bug has been marked as a duplicate of bug 99225 ***