Download it now!
Bug 113905 - Table AutoFormat changes table content
Summary: Table AutoFormat changes table content
Status: RESOLVED DUPLICATE of bug 106322
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss
Depends on:
Blocks: Writer-Tables-Style Table-AutoFormat
  Show dependency treegraph
 
Reported: 2017-11-17 14:17 UTC by cpohle
Modified: 2017-12-02 19:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cpohle 2017-11-17 14:17:23 UTC
Description:
When using the table AutoFormat function to apply a pre-defined table template, part of the contens of the table is deleted and replaced by "0".

Steps to Reproduce:
1. Create a new empty Writer document
2. Create a table
3. Put some text into the cells (or some of them)
4. Apply a table AutoFormat template

Actual Results:  
The table's content is modified (and cannot always be restored using undo!)

Expected Results:
Just format the table, content must not be modified under any circumstances!


Reproducible: Always


User Profile Reset: Yes



Additional Info:
This is severe, as data gets lost!


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Dieter 2017-11-18 08:31:14 UTC
Reproducible with

Version: 6.0.0.0.alpha1 (x64)
Build ID: c1d1f859b268f650143d48f294999cda0fa57350
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: group

I propose to change importance to major, because content of a table is changed.
Comment 2 Dieter 2017-11-18 12:19:56 UTC
You get the same result, if you use table styles from the sidebar. Is it the same or is this a new bug? By the way: What is the difference between Table-AutoFormat and Table Styles? For me it's confusing.
Comment 3 Buovjaga 2017-11-18 16:16:56 UTC
Yep, let's change severity to critical according to our flowchart: https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Dieter: I added you to contributors group so now you can change the priority and severity at will.
Comment 4 Yousuf Philips (jay) (retired) 2017-12-02 19:20:38 UTC

*** This bug has been marked as a duplicate of bug 106322 ***