Bug 113931 - MAILMERGE Add button to the Mail Merge toolbar to insert MM fields
Summary: MAILMERGE Add button to the Mail Merge toolbar to insert MM fields
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2017-11-19 11:41 UTC by Gabor Kelemen
Modified: 2017-12-18 08:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-11-19 11:41:34 UTC
When creating a Mail Merge document one usually needs to insert Mail merge fields. This is possible using the Insert - Field - More Fields menu.

However, there is no easy access to this window from the Mail Merge Wizard or the Mail Merge toolbar, making it hard to discover that one needs to use this during the document creation workflow, after setting up the data source.

I think it would be helpful to add a .uno:InsertField button to the Mail Merge toolbar.
Comment 1 Timur 2017-11-27 12:35:22 UTC
(In reply to Gabor Kelemen from comment #0)
> When creating a Mail Merge document one usually needs to insert Mail merge
> fields. This is possible using the Insert - Field - More Fields menu.
I guess you mean Insert - Field - More Fields - Database - Mail merge fields.
> However, there is no easy access to this window from the Mail Merge Wizard
> or the Mail Merge toolbar, making it hard to discover that one needs to use
> this during the document creation workflow, after setting up the data source.
With Bug 109118 in 6.0 I open Data Sources and then just drag fields.
> I think it would be helpful to add a .uno:InsertField button to the Mail
> Merge toolbar.
If you still find that button useful, please explain when it would be more useful than Data Sources and drag fields.
Comment 2 Gabor Kelemen 2017-12-16 08:32:01 UTC
Well just dragging fields could work, I suppose.
I was not aware of this feature, although it is documented and that part of help is displayed in extended help mode.
So it is possible to discover this feature, but the current toolbar does not exactly pushes it in your face.

Let the UX team decide on this, shall we?
Comment 3 Heiko Tietze 2017-12-16 09:56:59 UTC
Hard to imagine how this function could be implemented in the toolbar. There are so many sources and references that you likely end up in a situation where it's unclear to the user why a command is disabled. On the other hand, the implementation effort is high with not too much benefit. I would say WFM.
Comment 4 Timur 2017-12-18 08:01:52 UTC
So, we have "Data Sources" button in MM toolbar and a single click opens "Database selection". You browse to tables and drag fields where you want.
Proposal was (if I understood it) to add another button to MM toolbar that would open "Database selection" (and then also tables and fields). 
So, you would save that one click to open Data Sources but would loose visual overview of fields data, possibility to drag where you want and get that field at cursor position. 

Heiko didn't support this one. I don't know why he didn't close so I'll do it. Just because I also didn't understand the value of this comparing to the effort. 
Gabor, if you don't agree please set again as Unconfirmed. Or get someone in CC who could say more.