Bug Hunting Session
Bug 113952 - Java 8u151 not recognised by LibreOffice 5.4.3 64 bit version
Summary: Java 8u151 not recognised by LibreOffice 5.4.3 64 bit version
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2017-11-20 16:07 UTC by Daniel
Modified: 2018-07-31 17:21 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2017-11-20 16:07:57 UTC
Description:
My Zotero add-on installation failed due to Java issues. On going to Tools->Options->Advanced, no java runtime environments (JRE) appeared in the list. I installed the latest 64-bit version of Java (8u151) but the list was still empty. "Add" and selecting the Java folder also failed to find the JRE. I tried installing other versions of Java but nothing helped. Eventually I took a suggestion to install the 32-bit version of LibreOffice and this worked correctly with the Java 32-bit version installed. So it seems to be an issue with the 64-bit version. Problem occurred with LibreOffice Writer 5.4.3 installed on Windows 10 OS (all up to date).

Steps to Reproduce:
1. Install LibreOffice 5.4.3 64 bit
2. Install Java 8u151 (64 bit)
3.Tools->Options->Advanced

Actual Results:  
No items in list of JREs

Expected Results:
The Java version just installed should be in the list


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Buovjaga 2017-11-20 20:17:26 UTC
Java 8u151 64-bit shows just fine in 5.4.3 64-bit for me on Win 10.
So whatever this is, it seems to be system specific and possibly quite rare.
Comment 2 Rainer Bielefeld Retired 2017-12-30 18:26:54 UTC
NOT reproducible with Version: 5.4.4.2 (x64) 
Build-ID: 2524958677847fb3bb44820e40380acbe820f960 
CPU-Threads: 4; BS: Windows 6.19 (WIN10 Home Version 1703); UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group, my default user profile, Tango theme

Newly installed Java 8u151 64 bit shows up after few seconds in menu 'Tools → Options  → Advanced → Java'

@Reporter:
Any additional information you can contribute?
Comment 3 jmsksu 2018-01-21 21:58:10 UTC
I am also having this issue when I try to create a database.  I have the most recent versions of both LibreOffice & Java; I verified that Java is installed.
Comment 4 Buovjaga 2018-01-22 16:56:45 UTC
Maybe try one more time with a fresh master build to see, if there is some recent fix: https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/
Comment 5 Xisco Faulí 2018-01-23 09:02:25 UTC
To be certain the reported issue is not related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 6 QA Administrators 2018-07-31 09:38:03 UTC Comment hidden (obsolete)
Comment 7 Timur 2018-07-31 17:21:35 UTC
Since you both reporters didn't respond, I'll close. 
If you still repro with new LO version, please explain and set Unconfirmed.

Note: I have Win 7 with LO 5.4.7 64-bit working with JRE 64-bit, now jre-8u181-windows-x64.