Bug Hunting Session
Bug 113961 - [Navigator] Double-click on chapter shouln’d expand/collapse it
Summary: [Navigator] Double-click on chapter shouln’d expand/collapse it
Status: RESOLVED DUPLICATE of bug 36308
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2017-11-21 00:48 UTC by zyklon87
Modified: 2018-10-11 12:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zyklon87 2017-11-21 00:48:53 UTC
Description:
Whenever I want to navigate to another chapter by using the navigator (or sidebar), the chapter expands/collapses additionally, so I have all the time to double-click it a second time.

Could you please restrict expanding/collapsing to the arrow on the left side of the chapter? Maybe it’s useful, expanding it – but it shouldn’t be collapsed!

Steps to Reproduce:
1. Make a document with chapters and sub-chapters.
2. Open the navigator or the navigator pane of the side bar.
3. Double click the main chapters a few times for navigating to them.

Actual Results:  
Like above described.

Expected Results:
Like above described.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Heiko Tietze 2017-11-21 12:03:28 UTC
Let's keep it with the other tickets regarding the Navigator.
Comment 2 zyklon87 2017-11-21 22:02:13 UTC
That means?
Comment 3 Heiko Tietze 2017-11-21 23:21:58 UTC
(In reply to zyklon87 from comment #2)
> That means?

Status: New, Blocks: "Navigator"

Thing is that everyone seems to be afraid of touching this code, and there is likely no volunteer to fix your issue. But maybe someone perhaps in a GSoC project will start to implement a new Navigator.
Comment 4 Jim Raykowski 2018-01-02 03:08:28 UTC
I have sent a patch to gerrit for this filed under bug 36308
Comment 5 zyklon87 2018-01-02 17:48:05 UTC
Thank you very much!

I by the way just found out, that the styles tree view (hierarchy mode) already works like I requested the navigator tree view to work. I think it would be good if both tree views could just be implemented once, instead of twice?
Comment 6 Thomas Lendo 2018-10-11 12:03:06 UTC
As this was fixed in bug 36308, I'll close this as duplicate.

*** This bug has been marked as a duplicate of bug 36308 ***