Download it now!
Bug 113963 - PRINTING puts document into wrong page orientation.
Summary: PRINTING puts document into wrong page orientation.
Status: RESOLVED DUPLICATE of bug 92190
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-21 06:04 UTC by Robert Timmins
Modified: 2017-11-21 06:26 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Timmins 2017-11-21 06:04:12 UTC
Description:
When PRINTING, the printer dialog box shows the document rotated 90 degrees, as if in landscape mode, regardless of the actual page orientation. If the file is saved in any format, including when "printed" to PDF, the incorrect orientation is preserved. However, if the file is "exported" to PDF (not using the Print function), the orientation of the PDF file is correct.

Steps to Reproduce:
1.Open a new Writer Document (page orientation is portrait by default).
2.Enter some text
3.Click on "File/Print" (observe preview pane)

Actual Results:  
Print dialog box shows text in wrong orientation. Page prints in wrong orientation (rotated 90 degrees , ). If file is "printed to PDF" the incorrect orientation os preserved. File can be saved ("File/Save As") in any format and when re-opened incorrect orientation is preserved. However, using the "File/Export to PDF" option creates a PDF with correct (portrait) orientation.

Expected Results:
File should remain in portrait mode at all times, unless and until the page orientation is explicitly changed to landscape.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 5.3.6.1
Build ID: 686f202eff87ef707079aeb7f485847613344eb7
CPU Threads: 4; OS Version: Mac OS X 10.12.6; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group

Note: this problems was not encountered in the previously installed version of LibreOffice. This version of LibreOffice was installed immediately prior to upgrading OSX from El Capitan to Sierra.


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/604.3.5 (KHTML, like Gecko) Version/11.0.1 Safari/604.3.5
Comment 1 Mike Kaganski 2017-11-21 06:26:23 UTC

*** This bug has been marked as a duplicate of bug 92190 ***