Bug Hunting Session
Bug 113970 - CppunitTest_sc_parallelism crashes on master
Summary: CppunitTest_sc_parallelism crashes on master
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Calc-Threaded
  Show dependency treegraph
 
Reported: 2017-11-21 14:02 UTC by Dennis Francis
Modified: 2018-12-26 14:22 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
trace of the unit test crash (6.84 KB, text/plain)
2017-11-21 14:05 UTC, Dennis Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Francis 2017-11-21 14:02:49 UTC
Description:
After building LO from source, do

$ make CppunitTest_sc_parallelism

and it crashes.

Steps to Reproduce:
1. Build LO from source
2. run 'make CppunitTest_sc_parallelism'
3. it crashes

Actual Results:  
The unit test crashes

Expected Results:
no crash.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36
Comment 1 Dennis Francis 2017-11-21 14:05:44 UTC
Created attachment 137893 [details]
trace of the unit test crash
Comment 2 Dennis Francis 2017-11-21 14:12:52 UTC
Well, after trying the unit test many times, it does seem to pass without crash at times, so not always reproducible.
Comment 3 Commit Notification 2017-11-21 19:24:32 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=925af83ca4a383be854317ce41b7eb739c09ec32

tdf#113970 : blacklist vlookup/hlookup for threading...

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Stephan Bergmann 2017-11-22 07:31:09 UTC
What I see is two threads each with the stacktrace of attachment 137893 [details], apparently working on the same SvtBroadcaster instance without a mutex, causing crashes; any idea at what level a mutex lock is missing there?
Comment 5 Xisco Faulí 2017-12-25 14:40:21 UTC
A polite ping to Dennis Francis: is this bug fixed? if so, could you
please close it as RESOLVED FIXED ? Thanks
Comment 6 QA Administrators 2018-12-26 03:41:12 UTC Comment hidden (obsolete)
Comment 7 Dennis Francis 2018-12-26 14:22:36 UTC
The root cause of this crash (*LOOKUP was not thread-safe) has been fixed thanks to Luboš Luňák with commit 79449d73900d7a9bf061244d76f5f8eecc441198, so lets close this.