Download it now!
Bug 114018 - Yi (Nuosu) characters does not rotate in vertical layout
Summary: Yi (Nuosu) characters does not rotate in vertical layout
Status: RESOLVED DUPLICATE of bug 108302
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Vertical-Text
  Show dependency treegraph
 
Reported: 2017-11-24 08:56 UTC by Volga
Modified: 2017-12-08 08:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (9.73 KB, application/vnd.oasis.opendocument.text)
2017-11-24 08:59 UTC, Volga
Details
Test font (187.18 KB, application/x-zip-compressed)
2017-11-24 09:12 UTC, Volga
Details
My snapshot (38.59 KB, image/png)
2017-11-24 09:12 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2017-11-24 08:56:57 UTC
Description:
When vertical layout is enabled, Yi (Nuosu) characters does not rotate. Copying the following text you will see the problem:

ꀉꂿꅩꌺ
ꌒꆏꉘꃅꌒ,
ꉘꃅꌒꂸꐯ,
ꉘꃅꎵꑳꀕ,
ꉘꃅꑌꐥꌒ,
ꌒꆏꅔꐎꌒ,
ꅔꐎꌒꂸꐯ,
ꅔꐎꁤꇅꀕ,
ꅔꐎꏰꐥꌒ。


Steps to Reproduce:
1. Open Writer
2. Insert -> Frame -> Frame Interactively
3. Paste above Yi texts
4. Set Right-to-Left (vertical) direction for frame

Actual Results:  
All the Yi charaacters looks sideways instead of upright. See my snapshot.

Expected Results:
According to the Unicode Standard, their vertical orientation properties are U, so they should be upright in vertical text layout.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.0.0.alpha1+ (x64)
Build ID: d47aa694d0c6d10d52b7474b15e75a9462e991ff
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-11-24_00:21:48
Locale: zh-CN (zh_CN); Calc: group threaded


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Volga 2017-11-24 08:59:10 UTC
Created attachment 137954 [details]
Test file
Comment 2 Volga 2017-11-24 09:12:10 UTC
Created attachment 137955 [details]
Test font

This is Microsoft Yi Baiti, an Yi typeface included in MS Windows.

Alternatively, you can try following fonts for test:
Nuosu SIL http://scripts.sil.org/SILYI_home
Noto Sans Yi http://www.google.com/get/noto/
Comment 3 Volga 2017-11-24 09:12:40 UTC
Created attachment 137956 [details]
My snapshot
Comment 4 Buovjaga 2017-11-24 17:40:48 UTC
Seems to be Win-only as it's fine on Linux (I installed the font).

Version: 6.0.0.0.alpha1+ (x64)
Build ID: a0ebba3d8855fee0bcec04a10137ae3a4f9f0e77
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-11-22_05:59:17
Locale: fi-FI (fi_FI); Calc: group threaded

Version: 5.4.3.2 (x64)
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: fi-FI (fi_FI); Calc: group

Arch Linux 64-bit
Version: 6.0.0.0.alpha1+
Build ID: 008673c23db0c812eb0b48a1c29ab88b48aaa867
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on November 23rd 2017
Comment 5 Volga 2017-12-07 05:56:32 UTC
Fixed in bug 108302.

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 1d8cb97fea57b81a1ab151b88c2180e646bd401b
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-12-07_02:07:17
Locale: zh-CN (zh_CN); Calc: group threaded
Comment 6 Xisco Faulí 2017-12-08 08:06:22 UTC

*** This bug has been marked as a duplicate of bug 108302 ***